Sdkboxplay Sign in failed on android, error code: 8

Sdkboxplay Sign in failed on android, error code: 8

I got SdkboxGPGAuthentication W sign in failed:8 null and solved by bellow steps:

Check with Google Play Console

  1. Check game published on Game services
  2. Check game Alpha/Beta Test published
  3. Check API Console project SHA1




  1. Double check your APK [SHA1]

Project Settings

  1. Set your google_app_id with sdkbox-sample-ccc200/build/jsb-link/frameworks/runtime-src/
 <string name="google_app_id">1033290651465</string>

  1. Set "cloud_save": false, with sdkbox-sample-ccc200/build/jsb-link/res/sdkbox_config.json




"cloud_save": false, with sdkbox_config.json file.


Turning OFF and ON the Saved Games on Play console somehow fixed the signin() problem for me.
But then, when trying to saveGameDataBinary I got this “IllegalStateException: Must include Drive.SCOPE_APPFOLDER to use snapshots”. So I found a thread here on the forum that suggests updating to stage version. So I did update to stage version and now I’m facing the SdkboxGPGAuthentication: sign in failed:8 null error again :frowning:
Making the `“cloud_save”: false in sdkbox_config_json fixes the signing error, but makes me unable to save to cloud?


Ok. I managed to fix it!
Long story short its not a sdkbox problem but a google drive internal problem and they are currently working on fix.
Here is simple workaround till fixed - workaround instructions

To quickly check if your project is fixed you can use the link:

  1. Put you APP ID to ‘appid’ field
  2. Press Execute
  3. Authorize if required
  4. Check the Response code - if it is 200 your project is fixed.
1 Like

Thank you, i will try that!
What if I needed cloud save though?


Make sure sign-in works first.


I’ve disabled cloud save both in google play console and in the json configuration file.
I don’t get the sign in failed: 8 error anymore and the first time login worked.
But now it does not work…
I see this in the logcat:

2019-03-12 08:35:14.933 512-512/? D/SdkboxGPGAuthentication: SilentSignIn result:true
2019-03-12 08:35:14.947 512-563/? D/cocos2d-x debug info: GPG connection status changed: 1003

What does 1003 code means?
if I try to get player ID i get a void string:

2019-03-12 08:35:14.947 512-563/? D/cocos2d-x debug info: GPG Player ID: 

Can you explain better what that workaround does?
Do you know when a fix will be available?


There is a problem with signing in to a newly created projects on google play when cloud save is enabled . By using the workaround I’m now able to sign in and cloud save. Fix should be available in two weeks (per google drive team)


Could you please write here when the fix will be available so that everyone here (including me :sweat_smile:) can know whether the problem is resolved or not?
Thank you in advance.

1 Like

Thank you for the info.

1 Like

I still get this error even after turning off cloud save.
If I open the google games app I can see my game and the last played time seems to work though.
At this point I don’t know if the signin() is working or not for me

1 Like

Should be fixed now.


I confirm that it is working fine now.
Thank you very much.

Marking this as resolved

closed #35

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.