Sdkboxplay Sign in failed on android, error code: 8

Sdkboxplay Sign in failed on android, error code: 8
0
#4

Has the Sign-in UI displayed?
Have you upload the release-build APK to google console and make Alpha/Beta test AFTER added SDKBoxPlay?

0 Likes

#5

this is play console Create new poject savegame issue.
StateManager.cpp -> remove .EnableSnapshots()
and then sign success

1 Like

#6

this is new Project savegame issue.
remove .EnableSnapshots()

0 Likes

#7

in play console
this is create new poject savegame isuue.
StateManger.cpp —> remove .EnableSnapshots()
and then sign in success.

1 Like

#8

I’ll try this!

0 Likes

#9

I’m sorry but i do not understand, can you explain it better? Thanks

0 Likes

#10

The sign in UI does not display, but my game stops and becomes darker while a loading circle appears (i guess that’s part of the sign in ui).
I uploaded the release-build to google play in alpha test AFTER SDKBoxPlay integration, but the error persists.

0 Likes

#11

Maybe it has something to do with this:
I’ve also integrated firebase in my project, and firebase uses

<string name="google_app_id" translatable="false">1:795086958816:android:XXXXXXXXXXX</string>

So I had to change the google play games app id attribute name in

<string name="gpg_app_id">xxxxxxxxxxx</string>

Of course changed also in the AndroidManifest.
Is this attribute used somewhere else? (Maybe in the SDKBoxPlay sources)

0 Likes

#12

here is a google id conflict soulation. same as your’s.

http://docs.sdkbox.com/en/plugins/firebase/v3-cpp/#json-configuration

0 Likes

#13

Hello!
Thank you for your answer!
If you read carefully that’s exactly what I did!
I’m still stuck then… :frowning:

0 Likes

#14

error code:8

this should be something wrong in app config or google web config.

  1. can you double check keystore’s SHA (http://docs.sdkbox.com/en/qa/sdkboxplay_troubleshoot/#keystore)
  2. compare this sample project, to check project config. https://github.com/sdkbox/sdkbox-sample-cpp317/tree/sdkboxplay
0 Likes

#15

Hello, thanks for your answer,
This is my signing configuration:
I’ve joined two apps to the google play games console:

  1. The one for production, with the google play signing key
  2. The one for test, with my upload certificate, so that i don’t have to upload my app every time i want to test something about google play games

    Here you can see the sha1:
Impronte digitali certificato:
	 SHA1: 8F:7F:55:58:75:9D:A1:48:15:80:7A:7F:D3:A7:XX:XX:XX:XX:XX:XX
	 SHA256: 91:A3:59:F9:29:B1:B6:5E:3E:EC:B0:A2:76:DE:61:29:D4:63:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX
Nome algoritmo firma: SHA256withRSA
Algoritmo di chiave pubblica oggetto: Chiave RSA a 2048 bit

Both versions (downloaded from the google play store and installed directly) give me the same problem :frowning:

0 Likes

#16
  1. two apps in google play games console, which one are you use?

  2. use your app config on the sample project is another way.

0 Likes

#17

Hello,
Both apps on the google play games console are linked to the same google play app (same package name), the only thing that changes is the key (one for debug and one for production) but both ones don’t work.
(I’ve tried with one app linked but it does give me the same problem!)
I do not understand point nr. 2

0 Likes

#18

Did you manage to fix this!? I’m experiencing the same issue :frowning:

0 Likes

#19

Still stuck :frowning:
Hoping that someone can help us! :persevere:

0 Likes

#20

Created a clean 3.17.1 project just with a single signin(). Also repeated all steps in google console… yet again… error 8 :frowning:

0 Likes

#21

I got SdkboxGPGAuthentication W sign in failed:8 null and solved by bellow steps:

Check with Google Play Console

https://play.google.com/apps/publish

  1. Check game published on Game services
  2. Check game Alpha/Beta Test published
  3. Check API Console project SHA1

step01


step02


step03

  1. Double check your APK [SHA1]

Project Settings

  1. Set your google_app_id with sdkbox-sample-ccc200/build/jsb-link/frameworks/runtime-src/proj.android-studio/app/res/values/strings.xml
 <string name="google_app_id">1033290651465</string>

  1. Set "cloud_save": false, with sdkbox-sample-ccc200/build/jsb-link/res/sdkbox_config.json

DONE

Thanks,

0 Likes

#22

"cloud_save": false, with sdkbox_config.json file.

0 Likes

#23

Turning OFF and ON the Saved Games on Play console somehow fixed the signin() problem for me.
But then, when trying to saveGameDataBinary I got this “IllegalStateException: Must include Drive.SCOPE_APPFOLDER to use snapshots”. So I found a thread here on the forum that suggests updating to stage version. So I did update to stage version and now I’m facing the SdkboxGPGAuthentication: sign in failed:8 null error again :frowning:
Making the `“cloud_save”: false in sdkbox_config_json fixes the signing error, but makes me unable to save to cloud?

0 Likes