Sdkbox undefined reference to 'std::__throw_out_of_range_fmt(char const*, ...) error while compile for android studio

Sdkbox undefined reference to 'std::__throw_out_of_range_fmt(char const*, ...) error while compile for android studio
0.0 0

#21

Hi, When I integrate sdkbox with newly created test project then no error is coming.

But when I integrate sdkbox with my game project it is producing error.

Now I will try to recreate my project and then integrate it.

thanks for your support.

In case of any issue, I’ll tell you.


#22

Now i created a new project and installed sdkbox share plugin.

I am still getting the same error…

Anyone found the solution? Please help…Really stuck here…


#23

whats your env ? engine version, ndk, APP_STL etc…


#24

It would be great if we can take a look at your project if possible.


#25

@yinjimmy @nite

I am using -

cocos2dx 3.8.1
NDK r9
APP_STL := gnustl_static

Edit - Anybody found solution. Please help really stuck here…

Edit - @nite How should i show you the project?


#26

I also tried with cocos2dx 3.9, but i get the same error.

Any solution?


#27

strange. my env:

cocos2dx 3.8.1 pre-build framework
NDK r10d
APP_STL := gnustl_static

works with 3.8.1, 3.9, 3.10, 3.15, 3.16 etc…


#28

Hi @yinjimmy

I got it working with NDK r10d, Thanks…


#29

Thare are lots of cocos2d-x engines, NDK, gradle, etc… :frowning:


#30

Yes i tried so many and finally got it working with NDK r10d. It just consumed so much of time trying various versions of NDK and Cocos, which i want to put in developing app instead of trial and error…


#31

I have the same error

Cocos 3.4
sdkbox V2.3.17.5
NDK r10e
APP_STL := gnustl_static
use eclipse project

mihir77 said he got working with NDK r10d. Where to download this NDK version?


#32

ndk_r10d(December 2014)

Windows32-bit :http://dl.google.com/android/ndk/android-ndk-r10d-windows-x86.exe

Windows64-bit :http://dl.google.com/android/ndk/android-ndk-r10d-windows-x86_64.exe

MacOS X 64-bit :http://dl.google.com/android/ndk/android-ndk-r10d-darwin-x86_64.bin

MacOS X 32-bit :http://dl.google.com/android/ndk/android-ndk-r10d-darwin-x86.bin


Google ndk r10d .


#33

Thanks for fast reply yinjimmy!

My project works with ndk-r11c :slight_smile:

I also tried
ndk-r10d, ndk-r10e - throws error as in the topic title.
ndk-r15c - other error, seems my Cocos 3.4 is too old for this ndk and precompiled libs are not compatible.


#34

u can rebuild the precompile libs.