SDKBOX plugin Review (SOLVED)

I’m about to update a game on GooglePlay and wanted to add AppReview plugin as I have it working on iOS.

I have imported plugin doing “import review”:

 
$ sdkbox import review

  _______ ______  _     _ ______   _____  _     _
  |______ |     \ |____/  |_____] |     |  \___/ 
  ______| |_____/ |    \_ |_____] |_____| _/   \_
 Copyright (c) 2016-2020 SDKBOX Inc. v1.4.1.0
 Please reference the online documentation to finish the integration:
http://sdkbox-doc.github.io/en/plugins/review/v3-cpp/
 Installation Successful :)

I’m using v.3.17.2.

The extra step for Android is already done by SDKBOX, I just didn’t have to replace it:
Replace extends Cocos2dxActivity with extends com.sdkbox.plugin.SDKBoxActivity

The app installation on my device is OK with no errors, but when I run it, there is a black screen for about 1 second and the app close.

I tried creating a new HelloWorld project only adding the Review Plugin and same result.

What should I do in order to make it work like on iOS?

1 Like

We can ask @yinjimmy

1 Like

I updated my game on GooglePlay and I’m getting 392 downloads in 24h, but only 9 reviews… The game is a Halloween themed game, as they only spent 2 days reviewing the update to be available on the store, I still have time to update it again and have it ready until Halloween…

Please help!! @yinjimmy

let me check it later.
or
ask @htlxyz .

1 Like

crash? can you reproduce with follow sample? or share your sample.

plz try to add

<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>

to AndroidManifest.xml file.

Thanks,

1 Like

I have replaced the line <uses-permission android:name="android.permission.INTERNET"/> with the one you posted and now its working well.

Thanks @yinjimmy and @htlxyz

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.