SDKBox Fyber on Android

SDKBox Fyber on Android
0.0 0



I’m trying to integrate Fyber with mediation networks: AdColony, InMoby, UnityAds, AdMob and Vungle:

For the iOS, I followed the Fyber Integration guides, by downloading the frameworks manually and dragging to the XCode project. Everything seems to work fine.

When it comes to android, I’ve downloaded the *.jar for each mediation network and added it to:

The ads are not showing on android and I don’t know what do I need to do. Does anyone know what am I missing?


Have you modified manifest file?

If using android studio I’m usually creating custom folder for Jar files or placing them inside


If you’re using eclipse, it’s more tricky, we wrote a guide for it.

If you’re using android-studio, you can follow the fyber documentation.


I have no experience in developing for Android so when I created the project I was not able to setup eclipse neither android studio environment. The game was developed in XCode and until now everything was working fine on iOS and Android.

Can you tell me how can I do the integration manually? Is it enough do add the following jars to the folder?


If you want to use fyber mediation on android you have to build using eclipse or android-studio, it’s possible to build with cocos commandline, but nobody has figured it out yet.

So the first step would be get your project running on android-studio

then follow the guide, here


After configuring the project in Android Studio, the APK should be build with android studio or with cocos commandline?


If you config correctly, yes

cocos compile -p android --android-studio


I’m struggling for a few days now to make the game run on android device, using Android Studio.

I’ve tried the following:
cocos compile -p android --android-studio
cocos run -p android --android-studio
The code compiles without error, but when I run the game, it crashes instantly.
If I run the game from the Android Studio (Run Button), I get
java.lang.UnsatisfiedLinkError: dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/com.scp-1/base.apk"],nativeLibraryDirectories=[/data/app/com.csp-1/lib/arm64, /data/app/com.scp-1/base.apk!/lib/arm64-v8a, /vendor/lib64, /system/lib64]]] couldn't find ""

I’ve changed the a few times (located in: proj.androidn-studio/app/jni/
APP_ABI := armeabi and APP_ABI := armeabi-v7a

But it always crashes for the same reason.

What am I missing?


This more looks that you corrupted or in manifest file or in build gradle changed name of the lib to which cocos compile so cocos cant find it after compilation. Check under which name your cocos is compiled inside libs/obj folder.


The latest cocos2d-x android studio build has some problems… I think you have to build libMyGame first by yourself. Can you get your app running using?

cocos run -p android


Yes, it compiles and runs on the Android device. But GooglePlay and In-App Purchases are not working.


You can only test IAP with release build
GooglePlay not working will need to check on what the log says.


GooglePlay and In-App purchase working fine If I run the game using:
cocos run -p android -m release

But I think that Fyber dependencies configured in Gradle are not loaded when I compile with: cocos run -p android, because they belong to Android Studio Project.

It is possible to add Fyber dependencies to and not


It’s possible, but no body has figure it out yet. I think at this point is much easier just fix your android studio build. maybe ask in cocos2d-x topic I’m sure people had this problem before.


@nite I was able to fix the android studio project and now I can compile and run the app.
I’m using AdColony, InMoby, UnityAds, AdMob and Vungle for mediation but I can’t make them work.

Interstitials are not loading, the video reward is working but I think it’s loading from Fyber only, and not from mediation networks.

Gradle file Config:

repositories {
    maven {
        name "Fyber's maven repo"
        url ""

configurations {

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile project(':libcocos2dx')
    compile 'com.fyber.mediation:admob:9.6.1-r1@aar'
    compile 'com.fyber.mediation:unityads:2.0.5-r1@aar'
    compile 'com.fyber.mediation:adcolony:3.0.4-r1@aar'
    compile 'com.fyber.mediation:vungle:4.0.2-r2@aar'
    compile ''
    compile 'javax.inject:javax.inject:1'
    compile 'com.fyber.mediation:inmobi:6.0.0-r2@aar'

Do I need to add anything else? In iOS, the Fyber mediation configurations are pulled from the Dashboard, not sure if in Android it works same way.


Not sure but maybe needed SDK of that networks also not only mediation SDK’s?

Also check in dashboard to set top priority for test network to see if you get requests there. Check if you able configure that networks without mediation in your build, if they functions are available then you probably set everything fine.

Alsho check Android manifest if something should be changed there.


Hi @slackmoehrle @nite,

Do we still have to use android studio or eclipse to build apk? or we can use cocos console.


Still need eclipse or android-studio