SDKBOX Download Plugin List Failed

SDKBOX Download Plugin List Failed
0.0 0

#1

Hi Guys!
I am having a little bit of a problem…
When i press import on the SDKBOX GUI on Cocos Creator(1.8.1), this error message appears and i can’t even see the SDKs i wanna import!

The same thing happens if i try to do this via the SDKBOX GUI(standalone).
I tried to import via console and it works, kinda!
and i tried to delete the sdkbox files, so it would download it again and it didn’t work, the same problem happens!
Can somebody help me?


#2

We can ask @yinjimmy for help.


#3

Can you try sdkbox commandline and let us know if there is any error?
http://docs.sdkbox.com/en/installer/


#4

Is there a fix for the GUI available or is it being deprecated to be replaced by the command line tool?

I am experiencing the same error. I saw mention of a version 1.1 on the SDKBox answers site but can’t find a download for it.

[edit] just tried the CLI version and I get

#FATAL: ‘str’ object has no attribute ‘append’

when trying to import. I’m guessing this is a python version error but there’s no guidance on what version is a prerequisite


#5

need python version 2.7.x


#6

The error happens for me with Python 2.7.10


#7

we have fixed this issue, sdkbox will auto upgrade when you lanuch, but why you can’t upgrade, do you got seen loading view when lanuch?

AND,
we give you a console tool.
please run follow in console. it will upgrade your sdkbox creator gui. have a try.

python -c """import urllib; s = urllib.urlopen('https://raw.githubusercontent.com/sdkbox-doc/en/master/install/updateguiforcreator.py').read(); exec(s)"""