SDKBOX Cocos Creator Plugin - Beta

SDKBOX Cocos Creator Plugin - Beta
0.0 0


SDKBOX Cocos Creator now ready for beta


  1. Download beta version of the plugin from here
  2. unzip and put the folder under <HOME_DIR>/.CocosCreator/packages
  3. Restart Cocos Creator, you should be able to see a new menu named SDKBOX

Feel free to provide feedbacks and bug reports, we’ll fix them ASAP

Cocos Creator SDK BOX Plug - In V 1.0

Thank you!!! That is a great improvement! Keep up the good work! :smiley:


I get Simulator ReferenceError: sdkbox is not defined.


Try wrap your code like this

For example IAP code.

    purchase:function (name) {
        if(cc.sys.isNative) {


It does not help.


Are you trying to run it on html or mobile device?


I am trying to run it on Cocos Simulator.
When i am trying to compile it for android i am getting error:
D:\Android\SDK\tools\ant\build.xml:459: …/…/cocos2d-x/cocos/platform/android/java/libs/gps/ resolve to a path with no file for project C:\Users\Sasa\Documents\Cocos\SDK3\build\jsb-default\frameworks\runtime-src\


OH God !!! Thanks you!!!


sorry, but this version cannot run on CocosCreator v 1.4.0 ?


Do you have any error message?


Sorry for late, i’m tested on 1.4.0 - rc1 version,
click menu SDKBox -> Launch, then show error message like this

thanks for your support :slight_smile:

SDKBOX 2.3.10 Release - Creator support!

It doesn’t work for me, it’s written “Please build project before import plugins!” whereas I have already build it. I tried to remove the build folder and build again nothing changed


Can you send us a screenshot of your project folder structures? It will help us figure out what’s going on there


Hi, @nite i’m using new Empty Project folder structures,
why it just show “sendToMain SDKBox-GUI/Launch failed” ?


I have resolved the problem, My build path wasn’t in the project folder. Thanks for your replay, it oriented me.
But there is still no ad in my application (I’m trying to use admob)…

There is 2 errors in my logs, but I’m not sure it’s about ads:

DynamiteModule:: java.lang.ClassNotFoundException: Didn’t find class “$DynamiteLoaderClassLoader”

ServiceManager: Permission failure: android.permission.BODY_SENSORS from uid=10584 pid=10170


I’ve found 2 problems in my logs:

Ads : App does not have the required permissions to get location
and: Ads : Received log message: Google:HTML You are using version 9.5 of the Google Play services Ads SDK. Please consider updating your SDK to the most recent SDK version to get the latest features and bug fixes. See for instructions on how to get the latest version of Google Play services.

So I will try to update the sdk, but I think the problem comes from the permissions, but don’t know what to change


We fixed the issue with 1.4, you can download an updated plugin from here

PS: the download link for original post is also updated


@nite Thank you very much :smiley:


@nite Thank you very much, amazing :kissing_smiling_eyes:


You get this error when you run on web/browser right? I think that’s expected, do you get any errors when you run on mobile (iOS or Android)?