SDKBOX and firebase error

SDKBOX and firebase error
0

I have successfully implemented firebase cloud messaging to my project using the following link

https://firebase.google.com/docs/admob/cpp/cocos2d-x

In a separate project, I had implemented SDKBOX review, social sharing.

The current issue I’m facing is that I want to implement SDKBOX along with the exciting Firebase project.

Steps I have tried

1)Install firebase using pods and tried to implement SDKBOX

Result-Undefined symbol: sdkbox::Plugin Review::show(bool)

2)Install SDKBOX and implemented app rating and app sharing. Tried to install firebase using cocoa pods(Same steps as above)

Result-framework not found firebasemessaging

It would be great if anyone can help me out with the issue? And why is this conflict is occuring?

@yinjimmy @slackmoehrle

Interesting topic you got their

Would love to see a tutorial or something similar from @slackmoehrle and @yinjimmy

The community is in need of something like this for budding coders like me

I want to confirm your steps:

  1. sdkbox import review
  2. pod update

right ?

For Case 1-
I have installed Firebase using pods and after successfully installing it I have tried to install SDKBOX using the installer.

For Case 2-
I have implemented SDKBOX using the installer tool and after that I have created a pod file for the cloud messaging using firebase

after pod install , need to fix one issue:

TEST

case 1:

1.1 sdkbox import review

1.2 pod install firebase

compile ok.

case 2:

2.1 pod install firebase

compile ok.

2.1 sdkbox import review

~/repos/ccc231/build/jsb-link [master] $ import review --staging --nohelp
  _______ ______  _     _ ______   _____  _     _
  |______ |     \ |____/  |_____] |     |  \___/
  ______| |_____/ |    \_ |_____] |_____| _/   \_
 Copyright (c) 2016-2020 SDKBOX Inc. v1.3.2.0
  _                          _
 |o|  o ,      o_,'   o_,   |o|
 |O| <%'.   _`'_ ===  <\_   |O|
 (0) /  |  (_)`-' |    / |  (0)
 p----------------------------g
0) /Users/admin/repos/ccc231/build/jsb-link/frameworks/runtime-src/proj.ios_mac/Pods/Pods.xcodeproj/
1) /Users/admin/repos/ccc231/build/jsb-link/frameworks/runtime-src/proj.ios_mac/hello_world.xcodeproj/
type quit to abort
Select XCODE_PROJECT_DIR : 1
 downloading package sdkbox-review_v2.6.1.1.tar.gz
 http://staging.sdkbox.com/installer/v1/sdkbox-review_v2.6.1.1.tar.gz
 Please reference the online documentation to finish the integration:
http://sdkbox-doc.github.io/en/plugins/review/v3-js/
 Installation Successful :)

compile ok.

would you like to share the whole compile log.