Particle system. uimeshrenderer and trail module

I’m using particle system on my canvas. I know it’s important to add UIMeshRenderer component to particle system node.


Black part of screen is just sprite on canvas to see the difference

But Trail Module is not working with UIMeshRenderer component

Without UIMeshRenderer

With UIMeshRenderer

Currently the UIMeshRenderer component does not support multimaterials.

Okay, can you suggest any workaround please?

It‘s possible to use renderTexture to display particle system node in a 2d scene.

Hi! Thank you for your suggestion
It doesn’t seems right to me
Can you please check if I’m doing it wrong?

3.7.3 (5.3 MB)

Without render texture approach:

With render texture approach

Modify the camera settings for rendering rt.

Now the effects look correct, but I don’t want to solidify everything rendered before this camera.


Using 0 alpha doesnt look good

You need to customize the material and modify the blend mode of the material.

Camera settings

Material settings

Weird results

oh I guess I figured that out

Cam settings

Material settings

But what if I want to make one particle to fly over image A and another particle to fly below image A? Should I make one more render-texture? (55.3 KB)
Do you mean in this case?

Only problem I see is that context rendered by second camera is mirrored

The SAMPLE_FROM_RT parameter needs to be ticked.

1 Like