Particle System Position Type Bug (CC 2.1.2)

Particle System Position Type Bug (CC 2.1.2)
0

Something is wrong with particle system position type when I upgraded project to CC 2.1.2.

Position type mode FREE is not working correctly, particles fly all around, tested it on an empty project it’s the same. The particle should retain the same properties as in picture 1 but can move freely in space, but it starts shouting particles all around (think it’s because of tangential and radial acceleration properties).

Also for some reason, all the particles that were created to use free position type, switched to relative when I clicked on custom checkbox in the editor to check properties.

For test use the default atom particle and set the position type to FREE. You can check how particles behaved in CC 2.1.0 and in CC 2.1.2, I upgraded from 2.1.0 to 2.1.2 :slight_smile:

@jare @slackmoehrle

Also if it’s not an easy fix for cocos, is there an easy way to downgrade project back to 2.1.0 so I don’t have these problems?

Thanks in advance. :wink:


the performance of FREE mode at creator 2.1.2 is wrong
If you want back to 2.1.0, you can open your project with 2.1.0 directly

@Big_Bear I don’t know about performance, I’m talking about particle space that is wrong for some reason.

For test use the default atom particle and set the position type to FREE. You can check how particle system behaves in CC 2.1.0 and in CC 2.1.2.

Thanks for helping :slight_smile: .

Sorry, I means that the particle display in 2.1.0 is right and 2.1.2 is wrong, it is a bug in 2.1.2, we will fixed it

1 Like

@Big_Bear When I click on GitHub link I get: “This issue has been moved to a repository you don’t have access to.”

Is it going to be fixed soon? I customized engine end jsb adapter of CC for my game, and want to know is it an easy fix that will be fixed soon, or should I switch back to 2.1.0 ? I don’t know if 2.2.0 is going to get out soon and wait for it to :slight_smile:

Thanks in advance.

it will be fixed at creator 2.1.3

1 Like