Normal Map v2.33 , issue?


I just wanted to test the new 3D capabilities in v2.33 and it seems the Material channel for “normal map” doesn´t work. “Diffuse Map” works. But if i activate “normal map” the whole Object / Material turns out black! Even there is more than 1x light source.

Is it a bug ? Or do i have to set something sepcial, before apply an normal-map ?


Hi @sledgehammer ,
I was testing it several weeks ago. It wasn’t working on CC2.3.0 but seems like works on CC2.3.3 now. It shows weird at some angles though but still fine:

Thank you very much for testing it !
Strange, for me it doesn´t work. This is what i get :

Do you know why i am getting all black, by just applying a “normal map”-channel inside the material ?
(even the Build Export “Web-Desktop” is just black)

Send me the project to test here. I don’t know why it’s happening.

Thank you, for peeking into it ! Here is the project packed as zip : (1.8 MB)
Inside is also the ./build - folder which contains the web-Desktop export. Which is in my case also black :sleepy:

It seems fine in editor and browser preview but doesn’t work on simulator.
I found there is something wrong with lights. Only ambient light affects the object. Point light, spot light or directional light doesn’t effect object with normal map. Maybe @jare can take a look at this issue.

Thx for looking into.

You are right. “Ambient Light” works with normal map. But because of “ambient” it has no effect anymore.
Strange. In your editor i can see the normal map even with the point / Spot light. On my editor it is completely black. Not only in simulator mode, also inside the browser. Very sad :sleepy:

Ah, need to mention that normal-maps worked before in v2.20 with every light-source type !

I can’t use normal-map in v2.3.2 too.
Does anyone know how to solve it? :thinking:

Ok, you too. What i also found out, is that i even don´t have “specular”-shine on my surfaces. Really don´t know why. Maybe you can ceck this also out.

Specular works, if you check it, inside material-tab. Now on the newest version 2.41, the issue with the normal-map still not working. Also Export to web / mobile give some errors like: unexpected token, so it not loads.