Load Lua file in Android 11 and it cannot be loaded(LuaJit error)

error Log
[LUA ERROR] bad light userdata pointer

By November 2021 , all apps that are being updated must target at least Android 11 (API level 30).

luajit seems to have solved it. Please add the resolved build library to the engine. Please solve.

Can you help me please @slackmoehrle @pandamicro?

I don’t maintain Lua. I’d suggest filing a big report and then tag me. I’ll ask engineers if anyone knows and has time to solve this. I honestly don’t know the entire process to upgrade LuaJit.

Thanks for the comment.

I’ve asked the team for thoughts. I can reply once they have talked.

@pbs0512 we decided to update luajit to try to fix the issue. But we do not know if luajit resolved the issue. After upgrading luajit, could you please help to verify it as it is not convenient for use to release a game in google play. Thanks.

1 Like

Thank you very much. Hope it gets resolved soon.

I eagerly await the luajit update.
In November, it is impossible to update as targetSDK 30(android 11) must be supported.
Please as soon as possible.

@pbs0512 sorry, we are very busy these days. We will do it ASAP.

Please try to replace the corresponding libraries from GitHub - PatriceJiang/luajit-2.1-compile: compile luajit and verify whether the problem can be solved?

1 Like

@pbs0512 please check @PatriceJiang 's solution.

1 Like

Thank you very much. I’ll check and let you know if the problem is resolved.