JS Auto Code Completion not working

JS Auto Code Completion not working
0
#1

Hello,

I had just started playing with Creator.
For me Auto code completion is not working with VS Code for JS scripts.
I clicked on all this 5
image
May i know what else need to be done?
BTW for TypeScript its working fine.

0 Likes

#2

clicked “Install VS Code Extension” first,then clicked “Update VS Code API Source”
reference: https://docs.cocos2d-x.org/creator/manual/en/getting-started/coding-setup.html

0 Likes

#3

Not working…

0 Likes

#4

It’s not working for me too. Maybe in the other IDE (e.g WebStorm) it will work.
But I use VSCode. And my decision is to write code on typescript.
Please, write to this thread if you will find a solution.

0 Likes

#5

If simple auto complete is not working then how anyone can use this tool??
You should fix this first then add new features.

0 Likes

#7


check your config in preference->data editor.

creator version that you used?

it is works well on my computer

you can delete your creator.d.ts file and try again

0 Likes

#8

BTW I am trying on Windows-10, did you guys tested on Win-10?

Currently 1.9.3

I tried again, but still not working. But Type-script its working fine.


image
Please help me out and others as well.

0 Likes

#9

More VSCode screenshot, if you can debug problem
JS script


Type-Script

0 Likes

#10

@slackmoehrle This is really sad for cocos team.
If you cant support simple auto-complete then how can you see future in this tool??
Very disappointed.
Back to Cocos2d-x…

0 Likes

#11

I tested in win10 + creator 1.9.3
it seems all right

1D8D827245B8687FC2B1805CA2B10002

0 Likes

#12


So i think i found the issue, as per your screenshots cocos-creator extension should be installed, but in my case its not installed. Only Cocos Debug is installed.

I tried search in extension marketplace but not found any, see below

I am from India, if region is matter. Let me know how can i install that manually.

0 Likes

#13

you can try to install creator 2.0.8 and following those steps to install this extension.

if you install this extension success,you can change back to 1.9.3version and “Update VS Code API Source”

0 Likes

#14

@smitpatel88 let us know how you make out, ok?

0 Likes

#15

Sure, will try tomorrow now.

0 Likes

#16

@Big_Bear
So now i am trying in 2.0.9 and its working but its only working if project is created with 2.0.9.
All old projects its not working. (But not big issue)
Big issues :

  1. If i had created one script, Now i am trying to access that script into another script then i am not getting intellisense for the same. (No vars or methods etc)
  2. Still Auto suggestion is not working proper (Not like Cocos2d-x cpp)

Note: this 2 behavior is common for both Win & Mac

0 Likes

#17

you need to add your customized intellisense code in “creator.d.ts” file

0 Likes

#18

You mean manually?
If so then its really hard to make any game on this engine.

0 Likes

#19

yes, manually
or you can write your component used ES6 syntax, the IDE will recognize automatic.
another way is use typescript to develop your project

0 Likes

#20

Hmm Let me more dig into it.
Any example from your side?

0 Likes