Issues with admob after sdkbox update

I tried sdkbox update from 2.6.01 to the latest
I have Admob, Facebook, Firebase(analytics) plugins used.
All plugins got updated but when I hit the run button in Android Studio, my app runs but Admob is not working I’m getting errors like below:

Rejecting re-init on previously-failed class java.lang.Class<com.sdkbox.plugin.PluginAdMob$7>: java.lang.NoClassDefFoundError: Failed resolution of: Lcom/google/android/gms/ads/interstitial/InterstitialAdLoadCallback;

And another issue is when I try to build apk I’m getting this errors and not being able to build the apk:

/ sdkbox::AdMobProxy::nativeInit(sdkbox::Json const&): error: unsupported reloc 43
/ sdkbox::AdMobWrapperEnabled::nativeInit(sdkbox::Json const&): error: unsupported reloc 43
/ _GLOBAL__sub_I_PluginFirebase.cpp: error: unsupported reloc 43
/ sdkbox::ConfigManager::downloadConfig(): error: unsupported reloc 43

How do I solve it?

Engine ver: 3.16.1 cpp
Android Studio 3.6.2
Gradle 3.4.2
MacOS Catalina 10.15.7

sdkbox plugins used: Admob, Facebook, Firebase

seems like gms admob version does not upgrade.

I have not encountered this error. maybe you can check ndk version.

and you can check this sample project:

But banner ad is working… And the admob version is upgraded to
only the interstitial ad are not working.

I got this log in build window:

AGPBI: {"kind":"warning","text":"Type `com.cocos.lib.CocosActivity` was not found, it is required for default or static interface methods desugaring of `void com.sdkbox.plugin.SDKBoxCocosActivity.onCreate(android.os.Bundle)`","sources":[{"file":"/"}],"tool":"D8"}
AGPBI: {"kind":"warning","text":"Type `` was not found, it is required for default or static interface methods desugaring of ` com.sdkbox.plugin.PluginAdMob.createInterstitialView(java.lang.String)`","sources":[{"file":"/"}],"tool":"D8"}

I downloaded and replaced .jar files manually in libs folder too. But no luck.
Can you help on this?

If the banner is work, the integration should be successful.
maybe interstitial related code has been removed or confused by proguard.

if not work, maybe you need share a sample to me.

ok now it worked :smile:
I changed the version to

I hit-and-trialled a lot changing gradle plugin and gradle versions.
Now it’s working with Gradle Plugin 3.4.3 and Gradle 6.5 Android Studio 3.6.3.

But another thing is I have 3 android devices right now.
both the banner+interstitial ad are showing in only one old device samsung j2.

I tried resetting advertising id in other 2 devices but still no ads and even no logs from admob listeners.

Should I be worried? :worried:

Banner + interstitial ads are all showing, I think your Google Ads SDK integration has been successful.

I think you can try more devices. There must be something wrong if the ad always fails to display.

At the same time, you can try to show ad again after a while.