Issues setting up cocos2d-x on Linux

Issues setting up cocos2d-x on Linux


This is my first time posting and I am very new to cocos2d-x, so I apologize in advance for any seemingly simple questions on my part. I’m trying to learn to use cocos2d-x for a creative inquiry at my college (this is the required platform for the class).

I’ve been trying to set up cocos2d-x on Ubuntu 12.04 but I keep hitting a wall with every version of cocos I’ve tried using. Right now I’ve downloaded the latest version from the GitHub, and extracted the cocos2d-x directory to my Desktop. From here I ran ./ as it said in the readme, and then I made a TestGame directory in the cocos2d-x root and used the “cmake …” command to set up a new test project. In the readme it says after this to run “make -j4”, but there isn’t a Makefile in my TestGame directory, so I can’t run it. Am I supposed to make my own Makefile?

Anyway, the point of our class is developing games for Android, so I tried to do some exploring and make sure I know how to compile from c++ to Android. I went to the samples/Cpp/test-cpp/ directory and exported my NDK_ROOT to where I have it extracted. In the readme it says to run the script, but once again, this file does not exist in that folder. It doesn’t exist anywhere in my cocos2d-x installation, and I’m really confused as to where I’m supposed to find/generate it.

As I said, I’m very new to cocos2d-x but would be incredibly appreciative of any help I can receive with this. All the documentation and tutorials I’ve found haven’t been very helpful or up-to-date with the latest version of cocos2d-x.