iOS: TMS-90809: Deprecated API Usage - UIWebView

iOS: TMS-90809: Deprecated API Usage - UIWebView
0

i changed all as you say in pull in this file UIWebViewImpl-ios.mm
but still i am facing this issue
what next step i have to do ? @zhangxm

hi ! Please check your frameworks ex : firebase , facebook ,crasheslytic …

i use sdkbox how can i know which framework use UIVebView

SDKBox Team should update their plugins with latest SDKs to fix this.

1 Like

I am also getting a rejection from Apple. I updated UIWebViewImpl-ios.mm and upgraded skdbox dependencies:

  • facebook
  • admob
  • share

I ran:
grep -r “UIWebView” .
Binary file ./TwitterKit.framework/TwitterKit matches

./TwitterKit.framework/Headers/TWTRTweet.h: * Suitable for loading in a `UIWebView`, `WKWebView` or passing to Safari:

Binary file ./Bolts.framework/Bolts matches

./Bolts.framework/Headers/BFWebViewAppLinkResolver.h: A reference implementation for an App Link resolver that uses a hidden UIWebView

Binary file ./GoogleMobileAds.framework/GoogleMobileAds matches

It didn’t help. How can I figure out the cause?

1 Like

It’s about time to have this fixed once and for all! They need to update the SDKs ASAP! We can’t even test the game through TestFlight because the uploaded binary is rejected!

1 Like

C’mon guys. I desperately need the updates ASAP!

2 Likes

untill when SDKBOX is planning to update to latest sdks for removal of uiwebview? any hint?

1 Like

are waiting for sdkbox to update the sdks?

1 Like

We can only wait for the update.

1 Like

At least let us know when you plan to update !
Facebook, Firebase, AdMob - ok
UnityAds, AdColony - cause the issue.

1 Like

Dose sdkbox::iap inapp use uiwebview?

1 Like

I don’t think so.

1 Like

I was able to submit successfully by doing the following:

  • AdMob: there was a very long thread with google support on getting this fixed and they barely did it on time. See https://groups.google.com/forum/#!msg/google-admob-ads-sdk/QuZMbjIyxn8/jVQNNO5MAAAJ Essentially it’s fixed in AdMob sdk 7.56.0. When I updated sdkbox, the page shows that it pulls in 7.35.1. So I downloaded the latest version myself from google and replaced the frameworks.

  • Share plugin: Twitter appeared to be using it so I actually got rid of the share plugin altogether, it was buggy anyway especially - image sharing didn’t work for me.

  • Facebook: Bolts framework appeared to be using UIWebView. The sdkbox pulls in FB sdk ios: 5.0.1. “Facebook SDK doesn’t depend on Bolts since 5.0 and we removed usage of UIWebView in v5.5.0.” Reference: https://github.com/facebook/facebook-ios-sdk/issues/1035 I simply removed Bolts framework altogether and FB analytics still worked so I’m happy with it - I wasn’t using any other FB features.

With all that, submitted successfully.

2 Likes

Thanks! I will try this!

1 Like

I’m trying to do this, but there are too many SDKBox plugins using the old SDKs. Firebase, UnityAds, AdColony, Chartboost… Some of these have a major version change, so I doubt that replacing the frameworks with the latest will not cause problems in the plugins itself.

It’s time the SDKBox team fix this.

i have tried doing this, replacing sdk, chartboost have worked for me, admob and share is still needs to b done. will have to wait until sdkbox updates i guess

Those who are not using UIWebView in their Game/App and still receiving warning/error mail from App store.

Remove reference to these files:

UIWebView.h
UIWebView.mm
UIWebViewImpl-ios.h
UIWebViewImpl-ios.mm

1 Like

The issue with sdkbox plugins AdColony and UnityAds is solved ! Just replace AdColony.framework and UnityAds.framework from the official SDK.

The issue will be solved when the SDKBox team releases an update to the plugins. By the way, when can we expect the update?