IAB bug when disconnecting during transaction

IAB bug when disconnecting during transaction
0.0 0

#1

Hi there!
I’m receiving the “Purchase canceled - Response: 7:Item Already Owned” error on my game for android. I have received a reproducible step by step from QA for the issue:

Edited as wrong. The exact steps are in the next post.

It seems that disconnecting from the internet is setting the transaction state as unfinished forever. Can you confirm this, please?

Regards,
fryderyk


#2

Sorry, I missunderstand the info from QA. These are the steps to reproduce:

1.- Make purchase on any product.
2.- While the Google Play popup is on the screen, tap on the buy button and quickly disconnect the phone from internet (to simulate a disconnection after tapping on buy).
3.- Return to the game and the buy will fail.
4.- Connect to the internet again.
5.- Every call to purchase on the same product will give the “Item Already Owned” error.


#3

I usually don’t like to refer to anyone but this is a block for our game and we want it solved ASAP. As you helped me in the past with sdkbox, I invoke you @yinjimmy! :slight_smile:

Is it really a sdkbox issue or it is just my fault? As an extra info, I have been reported from QA that in-apps worked again after some time, at least an hour (they cannot be more accurate).

Thanks in advance for the help! :slight_smile:
fryderyk


#4

It’s ok to ref me with any SDKBox plugin issue.

I’ll test https://github.com/sdkbox/sdkbox-sample-iap with your steps.


#5

i don’t think this is a sdkbox issue.

3.- Return to the game and the buy will fail.

sdkbox just transmit google iap event to you, you got buy failed, so, this is a buy failed event send by google iap.

5.- Every call to purchase on the same product will give the “Item Already Owned” error.

and Item Already Owned event also is send by google iap.

so, i think you should take it as buy success.


#6

Sorry I think I explained myself wrong on the previous posts.

“Buy failed” is expected behaviour but the item is consumable, so later purchases would be allowed. So “Item Already Owned” is not expected behaviour.

Also the success callback is never called because no real purchase is done with the sequence of steps I wrote so take it as buy success is not an option.

Again, sorry for not exposing all the details before, that was my bad :frowning:

Hope we can find a solution quickly because the game is currently in soft launch! :slight_smile:


#7

Are you testing with real IAB product or the default android testing IAB product? The default one has the “Already Owned issue”


#8

I am testing it with a real IAB product.


#9

@nite Sorry for bothering you, no news?

Thanks in advance :slight_smile:


#10

We’re looking into this issue will update you ASAP