How Can I Localize apk (by Cocoscreator )

How Can I Localize apk (by Cocoscreator )
0

I’d like to make the localization only Japanese.
After making apk(by cocoscreator), I uploaded apk for googleplay.

localization like this↓↓↓
Because it’s a Japanese application, delivery area is limited to Japan.
If it’s no problem, I’m OK by the current state.
Is there a person who understands including a policy of google about this state?

I haven’t used cocoscreator but if you cannot select the languages in that program, maybe you can do it outside cocoscreator, like in xcode or eclipse or whatever? just a thought…

There’s a i18n extension in Creator’s extension store, I had to ask the author to have its English version. :grinning:

1 Like

thank you for reply.

I used compiled my app by Android studio.
Maybe There is a file related to localization, but I can’t found it.
It’ll be checked a little more.

thank you for reply.

I’m not too good at English, and I can’t be understood.
(what is 18n extension? ・・・・)
Excuse me…

But I’m glad thas you ask author.

I continue and investigate, too.
If there is some progress, I’ll report it here again.

i18n is short for internationalization. (because there’s 18 letters between ‘i’ and ‘n’)

1 Like

Currently, the i18n plugin is deprecated and should be removed. I don’t know why it still there, we will remove it tomorrow. You should translate the game in creator (implement your own JavaScript logic), not in Android Studio.

thank you for reply, jare.

I translated the game in creator From the beginning.

Maybe my application included i18n plugin.(build by cocoscreator 1.6.2)
It may be a problem of the version.
I wasn’t telling this. Excuse me.

But there was a solution method I found.
but I use Android studio.

When adding a cord to 「build.grande」 in the following, maybe it becomes compulsory.


android {
compileSdkVersion 22
buildToolsVersion “25.0.0”

defaultConfig {
    applicationId "xxxx.xxxx.xxxx"
    minSdkVersion 16
    targetSdkVersion PROP_TARGET_SDK_VERSION
    versionCode 4
    versionName "1.3"

    //localize japanease
    resConfigs "ja"
1 Like

Can someone whare some JS logic example how to localize Labels and Sprites? @jare maybe?

Thank you, I would really appreciate at least some guidelines

I still use the i18n extension for cc 2.0.9 without any problems. @jare is there a reason why this is deprecated?

2 Likes

My app also uses the i18n plugin. Now I have to update it (supporting 64bit architectures), but after updating Cocos Creator > 2.0, it won’t work anymore – due to i18n, as it looks.

@jare , is there any “replacement” for i18n? It would be great to have a migration guide or a simple replacement script, otherwise my game is broken…

Thanks for your help!

this has all the code needed for localization.

Thanks!

I removed all my labels that had a i18n component and replaced it with the ‘new’ LocalizedLabel component from the example cases.

So far, it seems to work!