Graphical artifacts are displayed when Hardware Acceleration is disabled

Graphical artifacts are displayed when Hardware Acceleration is disabled
0.0 0

#1

Hi everyone.

I have some graphic issues when disabling Hardware Acceleration on PC.
The game itself does not affect anything, just visual.
See the screen below that is displaying the border of animated sprite:

I am running on Chrome with windows 10 and built with Cocos Creator 1.3.1.

Does anyone know how to solve it?

Thanks


#2

Hi!
I’ve seen it happening on some versions of Chrome and Firefox. This bug seems to kick in when dirty region optimization meets sub-pixel rendering.
As an easy solution you can disable dirty region, it will have some performance impact but probably insignificant:

cc.renderer.enableDirtyRegion(false);

#3

It worked!
Them I did some extra search with enableDirtyRegion and there is a topic with same problem that I did’t see.

http://discuss.cocos2d-x.org/t/button-in-creator-have-border-when-hover-in-canvas-mode-render-web/34026

So my final code is:

if(cc.renderer.enableDirtyRegion != null){
cc.renderer.enableDirtyRegion(false);
}

Thank you very much persy for very fast solution.