Got lost inside the Tank Battle tutorial

I am a newbie trying to go through tutorials to get an idea how to create different types of games. I got through Part One of the Tank Battle tutorial just fine. At the beginning of Part Two, a Start page magically appears. There are no instructions how to create this page. So I created my own. I have it looking the same, but it is not responding to the scripts. I made sure that I am using the same Node names. Nothing happens when I press the Play button. Obviously, I did not create it correctly. I re-read the documentation. I started the tutorial again from the beginning. I found nothing useful to help me understand what I am doing wrong.

Any help will be greatly appreciated. What I am looking for is clear instructions how to create the start page.


Hi, may I ask which tutorial you are referencing? Is there a link?
And what version of Creator is used? Is there any error message reported?

I tried to follow that tutorial and it seems to be missing some parts. It assumes users already knows how to do things on their own or have read and understood everything in the manual.
However the documentation is quite difficult to understand and is more of a reference manual than a beginner entry point.
If you can manage to make sense of it, the best advice I can give you is to use the finished project from github and take a look at its different parts.
Good luck and be persistent. :wink:

Hey flashjaysan,
I am definitely a fan of reverse engineering. Thanks for the link.

Hey YuFang,

There was no error message. I know I did something wrong. Someone else sent the link to the completed project for me to reverse engineer. That should solve my problem.

Hey flashjaysan,
This is the same link I already tried. It looks like an incomplete starter project. The canvas is empty. All the assets are there, but the node tree is empty.

This was the first thing I did when I hit a wall. I am NOT a new programmer. Just new with Cocos.

1 Like

Oh! I didn’t checked the project before pasting the link in my previous message.
This is pretty shocking since the end of part 2 tutorial directs to this project as a finished one.

Sorry for wasting your time.