Google Play Services using Cocos Helper

Google Play Services using Cocos Helper
0

@SonarSystems: I tried implementing Google Play Services using Cocos Helper but I get the error “The hierarchy of the type GooglePlayServices is inconsisted”. (Image added below)

I also got an error in the manifest file.

Leaving the error, I tried to import the Google Play Services library but got an error in one of the files(Image added below).

My cocos2d-x project is in C-Drive while the SDK is in D Drive. Is this the reason for the red cross in the above pic?

@Kay_Kay
Thank you for using Cocos helper. I recently update the Game services code, but Google also updates the library, so please read this:

Google play services with cocos helper now need set Android Target to 21+. I can see that you already did that.
Why ? well there’s some that need the Android 21+ compiler that is because Google play services not cocos helper at all. Is better to have the your cocos2d-x project and Google play services projects and libraries in the same hard drive.
Please organize that is not a good idea.
It looks likes no one read the Logs error messages, it says that you cannot find support.v4, it means you need to import in your project android-support-v4.jar file. I’m not sure why some people need this is not really necessary to make it work but I’m pretty sure that is the final problem. If there’s any problem just write here.

Thanks @OscarLeif: I’ve already imported the jar file and it’s working fine now!

@Kay_Kay That’s good to hear, if you can you can add SOLVED to the post will be great.