[FINAL!] All in one Cocos2d-x&JS v3.7 is released

I’m sorry, I’m not good at English.
I am studying English.
Thank you for pointing out.

This should be fixed with pull request https://github.com/cocos2d/cocos2d-x-3rd-party-libs-bin/pull/169

1 Like

Thank you for your help.
Check the implementation, and then try to various challenges.

Hi, guys,

Thanks for all the feed backs, we have tested with our QA team too, now the RC0 is available to be downloaded:



Thanks for the fix, I have merged it, we will update the 3rd party libs tomorrow

Wow ! I love this engine first for its 2D and now in addition for 3D ! I will run my next project on 3.7 for sure soon !

now can not ping www.cocos2d-x.org from Tokyo, JP

[root@li388-203 ~]# ping www.cocos2d-x.org
ping: unknown host www.cocos2d-x.org

What is the diff between beta0 to RC0?
also any estimations when the final version will be out ?

Hi, I downloaded this version to test out the video function for JS.
When running a newly generated js project, this error occurs:
“cc is not defined”.
I couldn’t find a way to make it work… :confused:

EDIT: I cloned the latest version from github, and the same error occurs…

@pandamicro-Any Idea when the gold build will be released. We are eagerly looking forward to incorporate it

Still I got warning “Can’t find step change_direction” when I create an new project with “cocos”.

Should I change direction manually?

cocos2d-x-3 jaekwon$ cocos new test1 -p ai.furo.com -l cpp --portrait

WARNING: Can’t find step change_orientation.

The portrait direction will be supported by the template in v3.8, it’s already scheduled.

RC0 included some important bug fixes.
@EvilDeveloper @Meir_yanovich The final version will be out at about 20 July.

Which platform are you running the project ?
Are you running a new created project or the test case ?
Are you trying web or native build ?
How to reproduce the issue ?

I am running a windows 8.1 x64
I ran a newly created project:

cocos new test -l js -d c:\path\to\project\
cocos new test-nativeless -l js -d c:\path\to\project\ --no-native

I am trying the web build
I just run the command above, and the error occured.

Good news , i tested the test-cpp in old IPhone 4 ( it still very popular and i can see why , small and strong and now very cheap) .

any way i had to make small modifications in cocos2d-x

  1. in the test-cpp files i had to add allot of override operators ( allot)
  2. since im using the new xcode 7 beta 3 i had linking problem disable the new bitcode option.
    find more info here : http://stackoverflow.com/questions/30848208/new-warnings-in-ios9
  3. when loading the xcode project again the bundle names contains “-” in the name had to change it also

thats it , the 2d performance is very good and this is what i needed , some of the 3d stuff are working but slow as expected .
Cocos team please continue to support iphone 4 with the new versions . thanks.

The renderer seems to have broken our z-ordering that we had to fix once already in the transition from 3.3 -> 3.5. 3.6 behaved as 3.5 did. I’m trying to track down the issue. I believe it’s related to our usage of TMXTileMap and a custom “3d” sprite class based on BillBoard without the camera transformation. I’ve tried a combination of setting isTransparent and flags.

Does anyone know any major changes with respect to the sorting of transparent and opaque commands, or how CustomCommand should be used. The new material/technique stuff looks to be separated out and shouldn’t affect our rendering, so I’m not concerned about those changes. Maybe it’s something the final version will fix.

EDIT: FIXED the issue I wrote above!

The issue was caused by a test 3d cube model (no texture, only normals) along with an ambient and directional light. Removed it and game is rendering correctly again. The cube appears very small (10x10 pixels in screen space along one face) and is away from where the issue occurs (in screen space), but it must be affecting the rendering order of other commands. If I figure it out I’ll post here about what the cause was.

When creating javascript project like this in windows

cocos new -p com.jstest.org -l js -d g:\dev\cpp\2d\cocos2d-x-3.7rc0\cocos2d-x-3.7rc0\Projects JSTest  

when i excute JSTest.exe every thing is fine and the project working ,
BUT when i try to excute it under web server as html5 project
i get javascript error
in main.js :

cc.game.onStart = function(){ 

the source of the error is that the index.html is including the CCBoot.js file under

<script src="frameworks/cocos2d-html5/CCBoot.js"></script>

while cocos console does not create it in this structure
the directory structure looks like this :


as you can see no : cocos2d-html5/CCBoot.js
is it bug in the new tree structure of do i miss here something ?

Even i am facing same issue. Is there any change in steps to create project for web version?

I just changed the CCBoot.js file path in index.html to “frameworks/cocos2d-x/web/CCBoot.js” and then the sample app works fine.