File too short for libfmod

File too short for libfmod
0

i tried anything, this is the last wall i face before i get my game shows on the screen :lying_face:

/home/simoncillo/Desktop/cocos2d-x-3.17.2/build-AkrasielGame-Desktop_Qt_5_12_5_GCC_64bit-Debug/bin/AkrasielGame/AkrasielGame: error while loading shared libraries: /home/simoncillo/Desktop/cocos2d-x-3.17.2/AkrasielGame/cocos2d/external/linux-specific/fmod/prebuilt/64-bit/libfmod.so.6: file too short

No symlink worked… what to do ?
i have downloaded cocos zipi, unpacked, installed dependencies, created my project, added flag to CMakeFiles.txt, compiled all this successfuly, but when i run my game, this error comes up…

Show me the commands you executed for
each step exactly please.

  1. downloaded official zip 3.17.2 (I guess that is the last one)

  2. unzip the zip and moved the folder into desktop

  3. enter into unzipped folder in desktop and then entered into build folder

  4. execute install_dependency.py (I don’t remember name exactly my apologies)

  5. some errors comes up, but it shows what dependencies I need to install so I have installed them manually using apt-get install (±13 dependencies approximately)

  6. after all dependencies installed, I went to root folder and created my project
    cocos new Akrasiel -p linux -l cpp

  7. accepted license, then applied the tip about source and everything went ok…

  8. then vim the CMakeFiles.txt and added the flag you gave me at almost top bottom of the file in Windows or Linux section, save it.

  9. once that, I close terminal and open Qt Creator (the IDE I naturally use for many things, thanks God it support cocos!)

  10. Open Qt Creator and then open File or Project, then search for the CMakeFiles.txt and Qt Creator generated successfully the project.

  11. rebuild project (this took about 8 minutes).

  12. Everything looks very fine until here, so I press Play or Run button and voila… the error exist status 127 file too short error comes up…

  13. created the symlink using the same way as here:
    Here
    no error shows up!..

  14. returned to Qt Creator and try again, but same error occurs…

I am very close to see my game shows up, I feel that.

Ah you didn’t say you were using QT Creator before. You don’t need it to build the engine or a new project.

Are you on Debian 10? Or Ubuntu? Or?

Oh yes Slack, i forgot that, is not common to use Qt IDE for Cocos i guess :face_with_hand_over_mouth:

I’m using Debian 10.

Well you don’t need it to compile the engine or cpp-tests. Let’s make sure these steps work. Then cocos new. Then compile it. Then test it.

I’ll find time to make a virtual machine

1 Like

just to mind this…
the only strange error i receive was while executing install-deps-linux.sh was this:

btw, after that, i tried to install manually those dependencies and all of them were installed correctly except libpng12-dev that was not available, instead this, i have installed libpng-dev

I say this, because i have checked that i need to re-run install-deps-linux.sh again after generating symlinks for libfmod.so file …

But are you following our doc because you are doing steps out of order.

i followed just the same order as docs do.
the last part was to run, that is the part i have the problem Slack…
regarding to dependencies, i have re-run that (i mean, i have did that at its moment, and re do again after setting symlink as suggested in some post…

I don’t agree with this.

I’ll see about firing up a virtual machine and seeing what happens for me.

1 Like

great thanks man!

I can’t seem to get Virtual Box and Debian 10 working together. I’ll try to download the x86 version and see if that works.

1 Like

Great, what version of Debian are you using? I could try that too

I just finished installing 10.1 x86. Now I will set up Cocos and see how it works. I tried on 9.5 without fault.

Good, i will install 9.5 on vm too and see

I’m now using Debian 10.1 amd64 and am in the middle of make -j 4. I’ll keep you posted.

1 Like

I followed these instructions: https://docs.cocos2d-x.org/cocos2d-x/v3/en/installation/Linux.html

I selected dependencies for Ubuntu 18.

compiling successful:

On to the next steps…compiling a test app using cocos new ... successful:

i’ll follow v18 as you said and come back comment…
thanks!!

Yes, you should be using Ubuntu 18 all along. Debian 10 is very new. I will add Debian 10 to install doc just for clarity sake. Ubuntu is built on top of Debian.

1 Like

I just have downloaded Lubuntu 18, and will install it tonight… Thanks a lot for all your help…