[Feature]/[Bug]AutoAtlas undesired trimming

[Feature]/[Bug]AutoAtlas undesired trimming
0.0 0

#1

hey @jare

I came across this issue when trying to use AutoAtlas .pac files. It is automatically trimming empty space around images(pngs) that I’m atlas-ing together. This causes them to be different dimensions from their original files

I would prefer if there was an option to specify that the atlas would use the exact dimensions of the png(s) instead of trying to trim them first.


#2

I believe I found a solution to this by setting png properties in Assets tree view and setting Trim Mode to Custom, all 0 values, except for Trim Width and Trim Height to match w/h of image.


#3

It doesn’t matter. You can use Raw size in Sprite component. I believe you should always use trim, to reduce the cost of GPU pixel filling.


#4

@jare Great that works perfectly! Hope you get a chance to look at the Point Filter not working issue soon :wink: