Fbx-conv.exe from Blender 2.8

Fbx-conv.exe from Blender 2.8
0

Hello there. What version of Blender is compatible with the tool fbx-conv.exe?

exported as .obj works fine:
obj%20works%20fine

exported as fbx then converted to c3b or c3t i get this error:

c3t%20error

i tried fbx-conv.exe -f option to Flip the V texture coordinates but same error.

should i change any parameters on Blender? or what options should i use in the tool?

(not doing any animation on Blender just a cube with the logo as material)

thanks in advance.

I haven’t tested this in quite some time and fbx-conv hasn’t seen an update in a while now.

Do you recommend using the 3D features?

What advantage has .3ct/.3cb instead of .obj?

I use the features when I need to. I don’t notice any obstacles.

file formats: https://docs.cocos2d-x.org/cocos2d-x/v3/en/3d/tools.html

Thanks for that link. now i know.

i found this:
" A POT texture is where a texture has a resolution of 2^n x 2^n (which means the height and width is either 1, 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 4096… etc). NPOT is obviously the reverse of this, a texture which does not have a height/width which is a power of 2"

that was what the error was telling me.

i fixed that by using a 512x512 resolution texture image.

but i see a black screen and nothing else. This is the code:

ship = Sprite3D::create("untitled.c3t", "brickwork-texture.jpg");
ship->setScale(5);
//ship->setTexture("brickwork-texture.jpg");
ship->setPosition3D(Vec3(0, 0, 0));
ship->setRotation3D(Vec3(0, 0, 0));
ship->setForceDepthWrite(true);

auto rotate = RotateBy::create(3.2f, Vec3(360, 360, 360));
Action* repeat = RepeatForever::create(rotate);
ship->runAction(repeat);

addChild(ship);

and the output in console says something interesting:

cocos2d: warning: Attribute not found: a_normal

maybe i’m doing something wrong in Blender.

Do you know what is that a_normal attributte?

i had to use setScale(0.1f) because the cube is huge and the camera was inside the cube :expressionless: