Everytime we debug App we are getting strange error

Everytime we debug App we are getting strange error
0
#1

We are using cocos2dx 3.17.1, Android studio and whenever we are trying to debug our app it stops and when we click next step it resumes but we have no idea what cause of it and will it be a problem in future so anyone can please

#2

I don’t see any cocos2d in the call stack, do you know where it is starting from the engine?

#3

We have it too. Try adding other architectures in “abiFilters” in build.gradle file.

#4

what do you mean by another. can you please tell me what you have tried and able to solve this problem? if we keep going with this architectures will it be problem in future? thanks for reply :slight_smile:

#5

For example:

I have setting like this:

ndk {
    abiFilters = ["armeabi-v7a"]
}

If I run this on older device, with this architecture, breakpoint doesn’t hit. But I ran this on arm64 device this annoying thing pops out. Of course I can still continue, so it’s not a big deal. In onder to fix this you have to add arm64 like this:

ndk {
     abiFilters = ["armeabi-v7a", "arm64"]
}
2 Likes
#6

thanks, as you mentioned early, I had this into gradle.properties

PROP_APP_ABI=armeabi-v7a:x86

and then we changed it to

PROP_APP_ABI=arm64-v8a:x86

it’s working :slight_smile: Thank you