Error when running the genbindings.sh

Error when running the genbindings.sh
0.0 0

#1

when I execute cocos2d-x-3.0alpha0/tools/tojs/genbindings.sh I get:

chenyonghua-2:tojs chenyonghua$ sh genbindings.sh
Paths
NDK_ROOT: /Users/chenyonghua/workspace/android-ndk-r8e
CLANG_ROOT: /Users/chenyonghua/bin/clang+llvm-3.3
PYTHON_BIN: /usr/bin/python2.7
COCOS2DX_ROOT: /Users/chenyonghua/workspace/cocos2d-x/cocos2d-x-3.0alpha0
CXX_GENERATOR_ROOT: /Users/chenyonghua/workspace/cocos2d-x/cocos2d-x-3.0alpha0/tools/bindings-generator
TO_JS_ROOT: /Users/chenyonghua/workspace/cocos2d-x/cocos2d-x-3.0alpha0/tools/tojs
Using userconfig
[(‘androidndkdir’, ‘/Users/chenyonghua/workspace/android-ndk-r8e’), (‘clangllvmdir’, ‘/Users/chenyonghua/bin/clang+llvm-3.3’), (‘cocosdir’, ‘/Users/chenyonghua/workspace/cocos2d-x/cocos2d-x-3.0alpha0’), (‘cxxgeneratordir’, ‘/Users/chenyonghua/workspace/cocos2d-x/cocos2d-x-3.0alpha0/tools/bindings-generator’), (‘extra_flags’, ’’)]

…. Generating bindings for target spidermonkey

…. …. Processing section cocos2dx_extension

Errors in parsing headers:

  1. <severity = Warning,
    location = <SourceLocation file ‘/Users/chenyonghua/bin/clang+llvm-3.3/lib/clang/3.3/include/float.h’, line 86, column 9>,
    details = “‘FLT_DIG’ macro redefined”>
  2. <severity = Warning,
    location = <SourceLocation file ‘/Users/chenyonghua/bin/clang+llvm-3.3/lib/clang/3.3/include/float.h’, line 87, column 9>,
    details = “‘DBL_DIG’ macro redefined”>
  3. <severity = Warning,
    location = <SourceLocation file ‘/Users/chenyonghua/bin/clang+llvm-3.3/lib/clang/3.3/include/float.h’, line 106, column 9>,
    details = “‘FLT_MAX’ macro redefined”>
  4. <severity = Warning,
    location = <SourceLocation file ‘/Users/chenyonghua/bin/clang+llvm-3.3/lib/clang/3.3/include/float.h’, line 107, column 9>,
    details = “‘DBL_MAX’ macro redefined”>
  5. <severity = Warning,
    location = <SourceLocation file ‘/Users/chenyonghua/bin/clang+llvm-3.3/lib/clang/3.3/include/float.h’, line 114, column 9>,
    details = “‘FLT_MIN’ macro redefined”>
  6. <severity = Warning,
    location = <SourceLocation file ‘/Users/chenyonghua/bin/clang+llvm-3.3/lib/clang/3.3/include/float.h’, line 115, column 9>,
    details = “‘DBL_MIN’ macro redefined”>

Unknown cursor kind

Any idea what could be up?


#2

nknown cursor kind id:144,value:None
Unknown cursor kind

I found the Unknown cursor kind id is 144 which doesn’t exist in cindex.py . somebody can help?


#3

Hi, try to use ./genbindings.sh instead of sh genbindings.sh.


#4

I still get this error using cocos2d-x js 3.1, has this been solved?

Here is my output in windows command line
http://pastebin.com/3H0rvXeL


#5

I read from other thread, genbindings for windows is not working… Is it still not working for now?



#6

I am using cocos2d-x 3.5 and has upgraded to MacOS X 10.11, I got some error like Luke got before, so i wonder anyone success to run genbindings.py (in “/frameworks/cocos2d-x/tools/tolua/” for cocos2dx framework or in"frameworks/cocos2d-x/plugin/tools/pluginx-bindings-generator/genbindings-lua.py" for plugin-x) in MacOS X 10.11?
as it works fine for me along with previous verison of Mac OSX