Crashlytics on iOS. Crashes not reported

Crashlytics on iOS. Crashes not reported
0.0 0

#1

Hi, I have a C++ project in which I’m integrating crashlytics.
I’ve installed it via CocoaPods and I’m initializing it in AppController.mm using obj-c. I can force a crash using Crashlytics (in obj-c):

[[Crashlytics sharedInstance] crash];

and this is reported ok, I can see the crash on Fabric’s dashboard.

However when forcing a crash in my C++ code, for example throwing an exception:

throw std::runtime_error("OOPS... crash");

The crash is never reported.
I’ve ran the app on an iphone not connected to xcode and waited 10+ hours to see if the crash would show up on the dashboard.

Any ideas what might be wrong?

EDIT:

I also have Firebase in the game (for analytics) and it seems that removing it makes Crashlytics crash reports work.
I’ve tried initializing Crashlytics after Firebase (read somewhere that it needs to be initialized after all other 3rd party sdks) but this didn’t work either.

Is it possible to get crash reports from Crashlytics when also using Firebase?

EDIT2:
Ok… so now it seems to be working.
I don’t think I changed anything apart from initializing Crashlytics last. I’m raising an exception to make the app crash and throwing it from different parts of the code and the crashes are now always showing on Crashlytics’ dashboard.


#2

Hi, i’m trying to broke my App with this line:

std::abort();

The app crashes good, but the first time that the app crashes i don’t view anything in the dashboard. However, when i run again the app i can view the last crash in the dashboard. Is correct that it works at this way? Do not exist any method for informate the crash in the moment that it occurs?

And other problem is that not always Crashlytics informs the correct file/line that the app crashes. Anyone discover this issue?

Thanks


#3

This is because the crash is actually reported when you relaunch the app. So to see the first crash you must ran the app again and the crash will be reported after a few seconds.