Corrupted APK with CC 2.0.7

Corrupted APK with CC 2.0.7


Hi all,

after upgrading from CC 2.0.6 to 2.0.7 the APK cannot be installed on my Android devices. Everything seems to be fine except the following warning message:

‘Editor.projectInfo.path’ has been deprecated, please use ‘Editor.Project.path’.

I did not upgrade of modify anything in my project. And I deleted the old build folder.

What should I do?

Best regards,


@PZsolt27 I am going to ask the engineering team to read this thread.


Many thanks! :slight_smile:


The warning is not the main reason. Is there any other error message?


No, the build is successfull.


Can you manually uninstall the same APK from devices before install?


I tried both methods, to update and to install the corrupted APK. Today I will downgrade to 2.0.6 to check that version again.


could you upload the cocos console log file? so that we can found the details


Yes, of course. Just give me a few hours to get home. :slight_smile:

#10 (15.1 KB)

Here is the native.log file. I hope this helps.

Best regards,


Last of above native log, said that


60 actionable tasks: 60 executed
Move apk to C:\Users\PZsol\Cocos206\AriesPegSolitaire\build\jsb-default\publish\android
Build succeed.

obviously, the build process are successful after you click Build button. you should upload the native.log after Run failed.


I cannot install the APK on the device, so there is no RUN. The device says the APK is corrupt.


How can we continue to solve this problem? Did you try to build an APK? Or anybody else?


above native log is totally successful! that means no useful infos to help to solve this problem.

I cannot install the APK on the device

you should share us with error log, the log when you try to install but failed.


How can I get that error log? I install the APK directly from my Google drive and there is no additional information about the problem. Does it help if I share the APK with you?

Best regards,


As we known, the cocos creator build panel have 3 buttons, those are Build / Compile / Run. Since you have tried to install Apk into device, the Build process and Compile process must be succeful.

native.log only store one step log, if you click Compile, and then upload native.log, we will found log with no errors. if you click Run, and then Run process failed, at this time upload native.log, we will see the log with error details


why not install the Debug apk from build panel firstly


Ahha! This is what never worked… Then I’m going to fix this feature first.


Hi all,

after downgrading to 2.0.6 and clean installing 2.0.7 again, it created a working APK. I deleted all Cocos related folders to make sure it is a clean installation.

Best regards,