Cocos2dx v3.15 Android API 34 issue

Hi there,

Has anyone tried to compile cocos2dx v3.15/17 with Android API 34? I can’t get it done :confused: Here is what I get:

  • What went wrong:
    Execution failed for task ‘:app:processReleaseResources’.

AAPT2 aapt2-3.4.3-6197926-windows Daemon #0: Unexpected error during link, attempting to stop daemon.
This should not happen under normal circumstances, please file an issue if it does.

Ps. It builds well with API 33.

Maybe there is someone who alredy fixed it?

Thank you,

I have prepared a minimal sample that successfully builds with both CompileSdkVersion and TargetSdkVersion set to 34 on cocos2d-x v3.

I have confirmed the build with Android Studio Jellyfish 2023.3.1 and NDK Version 24.0.8215888.

The contents of the cocos2d folder use the latest version from the v3 branch on GitHub. Some modifications have been added since v3.17.2.
I have made adjustments in the file cocos2d\cocos\platform\android\libcocos2dx\build.gradle to enable building with the latest Gradle.

1 Like

Thanks @bluewind00 I will check it out. I think I have some configuration issue on my side with my cocos version.