Cocos2d-x v4 (C++) - not compliant with google play 64-bit requirements

Error message when trying to release:

This release is not compliant with the Google Play 64-bit requirement.
The following APKs or App Bundles are available to 64-bit devices, but they only have 32-bit native code: [16]

I have as far as I know built for all required architectures:
PROP_APP_ABI=armeabi-v7a:arm64-v8a:x86

I’ve also built an android app bundle as opposed to an APK, not sure if that’s the problem, or if cocos itself isn’t 64-bit?

Remove x86 from the PROP_APP_ABI list, since the market share of x86 Android devices is almost insignificant, and also because cocos2d-x doesn’t provide the x86_64 versions of the libraries. If you absolutely must have x86 and x86_64, then you’ll have to provide/build the required x86_64 libraries yourself.

1 Like

thanks again my friend!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.