Cocos2d-x v3.5 Released

Cocos2d-x v3.5 Released
0.0 0

#21

@hawkwood
We don’t know if it can run on 5.0 or not just because of lessing devices. We will change it if we can make sure that 5.0 is not supported.


#22

Thanks @hawkwood.


#23

Did you use Eclipse to compile c/c++ codes in Eclipse?


#25

#26

Hi @slackmoehrle, why unpinned this topic?
I think we should unpin previous versions of releasing note, such as 3.5rc0, v4.0alpha0 releasing note and so on.


#27

@zhangxm I’m sorry. walzer asked me a while ago to make sure we did not pin so many thing once that topic was replaced. When I saw v3.6alpha out I thought he would want v3.5 removed. I won’t remove stable build topic.


#28

#32

Thanks.
I agree that we should not have so many things, but it think it is better to unpinned more older ones.

And thanks to pin it again.


#33

Hi,

I noticed there is a coming upgrade to chipmunk v6.2.2
Im curious, why not 7.0 ?

Yours
Dredok


#34

I’ve upgraded my project from 3.3 to 3.5 and I’m working through several problems.

  1. [Solved] [Solved] Cocos2d-x 3.5 with PEShapeCache_X3_0.cpp
  2. all my physics bodies start at the same coordinates and then move outwards. I presume this is because they are colliding and as the collisions are resolved the bodies move outwards. This wasn’t happening with 3.3. The node started in the position I originally placed it. I’m wondering if I have to apply the PhysicsBody to the Node in a separate frame, after the Node has already been added to the scene.

Update: here’s a thread started by another user regarding the physics problem:


#35

Hi, when i run cpp-empty-tests or cpp-tests or if i create a new project a get this when i exit the game (exit code 1). I tried cocos2d-x-2.2.6 and it works fine (exit code 0).

I use windows 7 and visual express 2013

Ready for GLSL
Ready for OpenGL 2.0
OpenGL error 0x0500 in …\base\CCConfiguration.cpp cocos2d::Configuration::gatherGPUInfo 145

{
cocos2d.x.version: cocos2d-x 3.5
cocos2d.x.compiled_with_profiler: false
cocos2d.x.build_type: DEBUG
cocos2d.x.compiled_with_gl_state_cache: true
cocos2d.x.fps: 60
cocos2d.x.3d.max_point_light_in_shader: 1
gl.renderer: ATI Radeon HD 4600 Series
cocos2d.x.display_fps: true
gl.max_texture_units: 32
cocos2d.x.gl.projection: 3d
cocos2d.x.texture.pixel_format_for_png: rgba8888
gl.supports_vertex_array_object: true
cocos2d.x.3d.max_dir_light_in_shader: 1
gl.supports_ATITC: false
cocos2d.x.texture.pvrv2_has_alpha_premultiplied: false
gl.vendor: ATI Technologies Inc.
cocos2d.x.testcpp.autorun: false
cocos2d.x.3d.max_spot_light_in_shader: 1
gl.version: 3.2.9551 Compatibility Profile Context
gl.supports_NPOT: true
gl.max_texture_size: 8192
gl.supports_ETC1: false
gl.supports_S3TC: true
gl.supports_PVRTC: false
gl.supports_BGRA8888: false
gl.supports_discard_framebuffer: false
}

cocos2d: fullPathForFilename: No file found at /cc_2x2_white_image. Possible missing file.
‘cpp-tests.exe’ (Win32): ‘C:\Windows\SysWOW64\mswsock.dll’ cargado. No se encuentra el archivo PDB o no se puede abrir.
‘cpp-tests.exe’ (Win32): ‘C:\Windows\SysWOW64\WSHTCPIP.DLL’ cargado. No se encuentra el archivo PDB o no se puede abrir.
Console: listening on 0.0.0.0 : 5678
‘cpp-tests.exe’ (Win32): ‘C:\Windows\SysWOW64\WSHTCPIP.DLL’ descargado
El subproceso 0xdd4 terminó con código 0 (0x0).
El subproceso 0xda0 terminó con código 1 (0x1).
El subproceso 0x4d0 terminó con código 1 (0x1).
El programa ‘[1536] cpp-tests.exe’ terminó con código 1 (0x1).


#36

Hi

I’m using Armature + box2d for colision detection and I’ve found a crash in tests-cpp when I defined ENABLE_PHYSICS_BOX2D_DETECT and CC_ENABLE_BOX2D_INTEGRATION
in method b2BlockAllocator::Allocate
if (m_freeLists[index])
{
b2Block* block = m_freeLists[index];
m_freeLists[index] = block->next;
return block;
}
when i go to example Extensions->CocostudioArmatureTest->“Test Collider Detector”


#37

Using Particle3d PU all works well on IOS but on Android/eclipse,
I am getting the following error:
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUBoxCollider.cpp:49: error: undefined reference to ‘cocos2d::AABB::AABB()’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUBoxCollider.cpp:217: error: undefined reference to ‘cocos2d::AABB::containPoint(cocos2d::Vec3 const&) const’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUBoxCollider.cpp:223: error: undefined reference to ‘cocos2d::AABB::containPoint(cocos2d::Vec3 const&) const’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUBoxCollider.cpp:233: error: undefined reference to ‘cocos2d::AABB::AABB()’
make: Leaving directory `/Users/virgilwylie/Documents/Cocos2d/cocos2d-x-3.5/Gamerz/KungFuStreetFight35/proj.android’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUBoxCollider.cpp:240: error: undefined reference to ‘cocos2d::AABB::intersects(cocos2d::AABB const&) const’
The Selected NDK toolchain version was 4.8 !
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUBoxCollider.cpp:253: error: undefined reference to ‘cocos2d::AABB::intersects(cocos2d::AABB const&) const’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUPlaneCollider.cpp:130: error: undefined reference to ‘cocos2d::AABB::AABB()’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUSphereCollider.cpp:148: error: undefined reference to ‘cocos2d::AABB::AABB()’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUBaseCollider.cpp:101: error: undefined reference to ‘cocos2d::AABB::set(cocos2d::Vec3 const&, cocos2d::Vec3 const&)’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPURender.cpp:564: error: undefined reference to ‘cocos2d::s_attributeNames’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPURender.cpp:440: error: undefined reference to ‘cocos2d::Sprite3D::create(std::string const&)’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPURender.cpp:446: error: undefined reference to ‘cocos2d::Sprite3D::setTexture(std::string const&)’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPURender.cpp:451: error: undefined reference to ‘cocos2d::Sprite3D::getAABB() const’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPURender.cpp:453: error: undefined reference to ‘cocos2d::AABB::getCorners(cocos2d::Vec3*) const’
jni/…/…/cocos2d/extensions/Particle3D/PU/CCPUBillboardChain.cpp:667: error: undefined reference to ‘cocos2d::s_attributeNames’
jni/…/…/cocos2d/extensions/Particle3D/CCParticle3DRender.cpp:199: error: undefined reference to ‘cocos2d::s_attributeNames’
jni/…/…/cocos2d/extensions/Particle3D/CCParticle3DRender.cpp:242: error: undefined reference to ‘cocos2d::Sprite3D::create(std::string const&)’
jni/…/…/cocos2d/extensions/Particle3D/CCParticle3DRender.cpp:248: error: undefined reference to ‘cocos2d::Sprite3D::setTexture(std::string const&)’
jni/…/…/cocos2d/extensions/Particle3D/CCParticle3DRender.cpp:253: error: undefined reference to ‘cocos2d::Sprite3D::getAABB() const’
jni/…/…/cocos2d/extensions/Particle3D/CCParticle3DRender.cpp:255: error: undefined reference to ‘cocos2d::AABB::getCorners(cocos2d::Vec3*) const’
collect2: error: ld returned 1 exit status
make: *** [obj/local/armeabi/libcocos2dcpp.so] Error 1


#38

#39

http://www.fxpression.com/ is not working now please share another one to create PUParticle animation


#40

I fix it:add “LOCAL_STATIC_LIBRARIES += cocos3d_static” to “extensions/Android.mk”