Cocos2d-x v3.12 released!

Cocos2d-x v3.12 released!
0.0 0

#63

@zhangxm Sad to hear that. And …willlcocos creator support windows phone in the future?
Additionally, we are facing this isssue when trying to build android version. Please help us, the isssue is here: https://github.com/cocos2d/cocos2d-x/issues/16169
thanks so much


#64

@Pantoo i don’t know the plan of creator. Let’s ask @ShunLin about it.


#65

I just upgraded my JS project from v3.11 to v3.12 and had bug with loading remote textures :

Say my game is on http://www.mydomain.com/ and I do :

sprite.loadTexture("http://www.remotedomain.com/image.png");

The URL that is trying to be loaded is : http://www.mydomain.com/http://www.remotedomain.com/image.png

I found this commit to be resposible, in file TexturesWebGL.js line 918.
Please fix this.


#66

Instructions?


#67

I think we can handle that. Let me find where they are.


#68

I am still using v3.10 . I am scared to update it because i have done modification to the render texture and sprite source files. I had some issues in Windows universal apps running on Microsoft phone devices (windows 10) . We are heavily using Render Texture and for some reason the new polygon instead of quads for sprites were causing huge performances issues when used with Rendered Texture. Is the issue been fixed . here is the link if anyone wants to replicate the problem. I had to change the code so that it had to use old quad code instead of the triangles to solve the problem. Still not sure exactly what was the problem. (Solved) RenderTexture is very slow on 3.7+ versions


#69

This is what the engineering team referred me to: https://developer.android.com/google/play/expansion-files.html and also mentioned that it can only be used with Google Play.


#70

Hello, can you tell me what “** fixed Android performance issues*” covers? Is this directed at devices with version 6.0+? I’m having touch related issues exclusively with my S7 with 6.0.1. I have a game loop on a separate thread, when touch input is happening I get much faster game loop cycles, when touch input is not happening more cpu is used and I get slower cycles (4-5ms per frame when there is touch input, and 10-14 when there’s no touch input). On other devices (S3, and an older samsung tablet this is not happening at all).


#71

when i try to test the app in real android device it says “unfortunately app has stopped”
please help me .


#72

More info on this: about the rendering update https://github.com/cocos2d/cocos2d-x/issues/15652 and the audio https://github.com/cocos2d/cocos2d-x/pull/15875.


#73

@noafsalman456
Read this:


#74

Im having the same issue with upgrading to 3.12.
How can do that? (adding Core Text to the project). Thanks!


#75

You can click on your project in Xcode, then goto General, scroll down to Linked Libraries and Frameworks and use the + button. Add CoreText.framework


#76

It works! This was mi first upgrade to new version :smile:
Thanks!


#77

hello everyone:
i have some problem in this version for cocos2d-x 3.12
i download this version in my mac os . my os ver is 10.10.5 and my xcode ver is 5.1.1.
today i setup this in that. and i create the helloword demo in bash to the desktop. but when i build it in xcode,there have one mistake about:
/Users/it/Desktop/HelloWorldDemo/cocos2d/cocos/platform/ios/CCDevice-ios.mm:348:42: Cannot initialize a parameter of type ‘NSStringDrawingOptions’ with an rvalue of type ‘int’

this is have mistake code:
static CGSize _calculateStringSize(NSAttributedString *str, id font, CGSize *constrainSize, bool enableWrap, int overflow)
{
CGSize textRect = CGSizeZero;
textRect.width = constrainSize->width > 0 ? constrainSize->width
: CGFLOAT_MAX;
textRect.height = constrainSize->height > 0 ? constrainSize->height
: CGFLOAT_MAX;

if (overflow == 1) {
    if(!enableWrap) {
        textRect.width = CGFLOAT_MAX;
        textRect.height = CGFLOAT_MAX;
    } else {
        textRect.height = CGFLOAT_MAX;
    }
}

CGSize dim;
dim = [str boundingRectWithSize:CGSizeMake(textRect.width, textRect.height)

options:(NSStringDrawingUsesLineFragmentOrigin|NSStringDrawingUsesFontLeading)
context:nil].size;

dim.width = ceilf(dim.width);
dim.height = ceilf(dim.height);

return dim;

i really cant konw what is it .plz help me ,


#78

You need Xcode 7+ for v3.12


#79

#80

same issue with me, and i also got the error on mac build
osx 10.10, xcode 6.0.1, cocos 2d-x v.3.13.1


#81

You need XCode 7+


#82

Great ! Thanks for the tips ! Had the same issue and worked.