Cocos2d-x v3.10 released

Cocos2d-x v3.10 released
0.0 0

#146

@slackmoehrle
Can you please check download links for cocos? It seems that part of site is down getting error trying download cocos.


#147

Thanks, I am fixing it now.


#148

@slackmoehrle

When I run any cocos command, it always show the error :

/Applications/Cocos/Cocos2d-x/cocos2d-x-3.10/tools/cocos2d-console/bin/cocos: line 8: shell_session_update: command not found

What’s the problem?


#149

I don’t know, what is your locale set to?


#150

I don’t know where is the locale should I check ?
Please show me.


#151

echo $LANG


#152

Here is my Mac : en_US.UTF-8.
Thanks,


#153

hmm, that should be fine.

I’d file a GitHub issue for this, please.


#154

Thank @slackmoehrle.


#155

Perhaps this is an issue with older versions as well, I’m not sure. The TMX function() getTileGIDAt() fails to return anything other than 0.

I have found this issue raised only in recent threads on Google, i.e. 2014+, so I have to assume it’s an issue with v3.x. No one had found an answer as far as I could tell. I was following the RayWenderlich tutorial (replacing deprecated items with the appropriate replacements), and I ran into this issue when trying to run collision with TMX layers. No matter whether I had one layer or multiple, whether the whole layer was filled in or not, I kept getting the same problem.

I stepped into the getTileGIDAt() function, and it appeared that, no matter what Point/Vec2 I provided, the idx[point] was set to 0. What the hell??

Basically, I’ve been working around the issue by using Objects, which seem to work fine. I can see the obvious utility of layers though, and it’s frustrating that this functionality is broken (at least, it seems). Am I missing something? Are you?


#158

I use that function and i dont have any issue…