Cocos2d-x v3.10 released

Cocos2d-x v3.10 released
0.0 0


Will it be possible in future versions to import Spine SkeletonNode into Cocos Studio?


I really need that as well. (spine to cocos studio feature)


Is the LabelTTF/ccui.Text newline bug still in 3.10? I mean the bug where when you let pass a long string to the LabelTTF/Text, it will sometimes create newlines such that there is an empty space in the beginning of a line.


Fantastic job on the new Cocos installer! I just moved over my 3.9 source code version to the 3.10 prebuilt and it worked perfectly without a single hitch.



  • When I create a new class that inherits UI::Layout class, if I enable Touch on it, the app will crash when I click on the Layout itself.

class NewLayout : public ui::Layout


//bool init in .cpp file


Do you call the base class in methods like init()?


No. i use NewLayout::create()


Yes but in the overridden init() method do you call the base-class init() method first?


@cdang normally you do not enable touch on an entire layer. But maybe you have a reason I don’t understand.

Here is an explanation that might shed some light from one of the develoepers:

I hope that helps.


No, I did not call init() inside the override init(). I added Layout::init() and it works now. Thx.

I need a containment layer because I need to be able to add more customized functions and settings; not just for handling touch or base class features.


Okay, but can’t you still add them using the new methods instead of setTouchEnabled?

Also, does it need to be a layer? What about using a Node to catch the events and add your items into the node or above it in the same layer?


I see cocos2d-x v3.10 run Android Studio very good.


I hope admin can build document create type pdf.


Hi there,

So I freshly downloaded the new “Cocos” product. I’ve successfully got it to compile for XCode using source code only. For the life of me the Precompiled libraries would not work. I’ve got the latest and greatest versions of XCode and OSX. This is starting from scratch (i.e. hitting new project, open in XCode, build and run).

Unfortunately I cannot get Android to work no matter what I try. Again I start from scratch and select “New Project”, C++, no extras, source code. When I open in Android studio it all builds, but when I run on my android device it says:

Unfortunately, libcocos2dx has stopped.

java.lang.UnsatisfiedLinkError: Couldn't load cocos2dcpp from loader dalvik.system.PathClassLoader[dexPath=/data/app/org.cocos2dx.testapp-2.apk,libraryPath=/data/app-lib/org.cocos2dx.testapp-2]: findLibrary returned null

And if I run it on the default emulator: Nexus 5 API 23 x86

Unfortunately, libcocos2dx has stopped.

2-27 14:47:45.103 2445-2445/? E/AndroidRuntime: FATAL EXCEPTION: main
                                                 Process: org.cocos2dx.testapp-2, PID: 2445
                                                 java.lang.UnsatisfiedLinkError: dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/org.cocos2dx.testapp-2-1/base.apk"],nativeLibraryDirectories=[/data/app/org.cocos2dx.testapp-2-1/lib/x86, /vendor/lib, /system/lib]]] couldn't find ""
                                                     at java.lang.Runtime.loadLibrary(
                                                     at java.lang.System.loadLibrary(
                                                     at org.cocos2dx.lib.Cocos2dxActivity.onLoadNativeLibraries(
                                                     at org.cocos2dx.lib.Cocos2dxActivity.onCreate(
                                                     at android.os.Handler.dispatchMessage(
                                                     at android.os.Looper.loop(
                                                     at java.lang.reflect.Method.invoke(Native Method)

Any help would be appreciated. I haven’t even begun trying to integrate my actual project – this is all running with what I assume is a hello world project.

P.S. the name “Cocos” makes it hard to search for other people’s issues on google relating to this GUI Project builder since other cocos projects come up first. For the sake of google searches maybe a unique name would help? For instance: Cocoscape or Cocosphere. Just a suggestion.


@jaunt you can currently only run fromAndroid Studio, but not compile. It’s crashing because you’re missing your game’s library.

To get it working you have to call the following command in your terminal:

cocos compile -p android --android-studio 

When it’s done compiling, you can run your project from Android Studio


Hi, I am having trouble with my Cocos2d-x v3.10. I am unsure of how to setup it and would really appreciate some help. Thanks


I have a problem loading a scene created with Cocos Studio.

If I use the callback feature

auto rootNode = CSLoader::createNodeWithVisibleSize("MainScene.csb");

This always return NULL. But if I left the Advanced > Custom Class field blank, the scene loads normally.

Do you have a reported bug like this? Also a solution?

[SOLVED] Appearently in CSLoader.cpp 1052 the custom class appends the word Reader to find the reader. So if you put that name with the Reader word included (e.g. MyClassReader) it wont work.


Can I suggest to update the documentation to make this point clearer. Thanks.



did this release break something on the multi-resolution support?
when I try to get the screen resolution using glview->getFrameSize() on a iphone 6 device, it gives me iphone 5 resolution. This problem does not occur on cocos2d-3.9



can you help me with this issue?cocos studio crashed


@newguy make sure you have the right sizes for launch images