Cocos2d-x v3.10 released

Cocos2d-x v3.10 released
0.0 0

#42

I can reproduce this on my end and have provided more info to the engineering team.


#43

Can you tell me what Windows version you are using?

Also, the engineering team ask me if you were out of disk space. I assume you are not, but can you confirm?


#44

It will be available on January 27th.


#45

I just realized that the machine I used for testing was actually running the most recent Insider build of Windows 10 (1102) rather than the last stable release. On my other machine, which has a stable Windows 10 installed, everything works fine. So perhaps this is a temporary Windows bug that will be fixed in a later build.


#46

Interesting, thanks.


#47

I got an error running “cocos new…”

File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/locale.py”, line 475, in _parse_localename
raise ValueError, ‘unknown locale: %s’ % localename
ValueError: unknown locale: utf-8

Fixed with:

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8
source ~/.bash_profile

#48

Yes, that is the fix.


#49

Hi I started a new project cocos2d-js yesterday with Cocos all-in-one, everything goes fine, but when I tried to compile for web platform the console result is the following:

ANT_ROOT not defined. Please define it in your environment.

I looked at the Applications->Cocos and tried to find the .bash_profile to set the ant_root, but I couldn’t get to the file. Can someone help me please


#50

This is minor, but I see that Cocos on OSX uses one of those password boxes (for login) that won’t allow you to paste text into it. That’s kind of annoying since I use a password generator for all of my login info, typing dozens of random characters blindly into a password field is an exercise in frustration. Is the extra security on that field really necessary?


#51

I somehow managed to build my old project with cocos2d-x 3.10. Here is a strange issue:

Old project (3.8) Application.mk

APP_STL := gnustl_static

APP_CPPFLAGS := -frtti -DCC_ENABLE_CHIPMUNK_INTEGRATION=1 -std=c++11 -fsigned-char
APP_LDFLAGS := -latomic

APP_ABI := armeabi armeabi-v7a



APP_CPPFLAGS += -DCOCOS2D_DEBUG=1
APP_OPTIM := debug

APP_CPPFLAGS += -DNDEBUG
APP_OPTIM := release

APP_PLATFORM := android-15

3.10 Application.mk

APP_STL := gnustl_static

APP_CPPFLAGS := -frtti -DCC_ENABLE_CHIPMUNK_INTEGRATION=1 -std=c++11 -fsigned-char
APP_LDFLAGS := -latomic

APP_ABI := armeabi armeabi-v7a

ifeq ($(NDK_DEBUG),1)
APP_CPPFLAGS += -DCOCOS2D_DEBUG=1
APP_OPTIM := debug
else
APP_CPPFLAGS += -DNDEBUG
APP_OPTIM := release
endif
APP_PLATFORM := android-15

With the new one, rapidjson IsString() function fails. When i change it to the old one, it works.


#52

What I think is happening is that the Cocos tool doesn’t respect if you have ANT_ROOT or an Android environment already defined.

Look at what is in Cocos -> Preferences -> Platform.

There is also a one-click configure option that you can try


#54

Congratulations!! Thanks for the great work. I am looking into the Jquery for some of the text input etc. I hope cocos2d-x can support more on application type of features, like text input, media auto/video recording, etc.


#55

Question to @slackmoehrle
Is cocos team working on new platforms like tvOS, androidTV, watchOS, android wear? Only for tvOS there’s an unofficial solution.
Also, what’s even more important, what about android studio support. I mean real support. With gradle, debugging etc. On precompiled libs :slight_smile: Many people asks for that.


#56

We are talking about tvOS support. Other platforms don’t even use OpenGL (like WatchOS) so we can’t support this right now.

We support Android Studio now, but I think we don’t do everything with gradle and debugging perfectly at this point. I really don’t know what aspects of Android Studio support we are currently lacking.


#57

Thank you. That worked \m/


#58

Great news! Thanks for all the awesome work on this. I already moved my project to 3.10 and works like a charm.

@slackmoehrle Do you know if this is the proper place to post Cocos Studio bugs/requests ? It doesn’t seem to have much activity.


#59

I don’t know about WatchOS, but I’m pretty sure both Android TV and Android Wear do support OpenGL. On LG G Watch I was able to run my cocos2d-x game from eclipse. It worked, but ofc it needs some enchantments for smaller screen and somehow be packaged within smartphone app (because you can’t install apps directly at user conditions). I was even able to run game made in Flash (air sdk) :smile:
I’m sure it’s similar for Android TV.

As for android studio I’ve just created 2 test projects:

  1. NewCocosProjectPrecompiled

  2. NewCocosProjectSourceCode

  3. yells “Only a cocos source code project can be opened in Android Studio”. Why can’t precompiled project work in Android studio?

  4. Project opens, but I only “Nothing to show” in Project panel, I can’t run app (run is grayed out).

Anyway SourceCode is no-go for me. It compiles too long and takes too much space.


#60

Thank you for this new release!

Just a quick question, what is the right way to update an existing project?
In the past I’ve done this:

  1. Extract the new cocos zip, running setup.py
  2. Create a new project for my App
  3. Copy my Classes and Resources, platform related files in this new App.
  4. Compare the old and the branch dir to see if I have forgotten something.

Is there a more automatic way to upgrade?


#61

It is not the proper place and we really don’t have a place. You can use the Cocos app to provide feedback. You can always send to me and I can communicate it as well.


#62

It depends, are you using the pre-built libraries? If so, it becomes really easy.

The Cocos app will have upgrade functionality built into it soon.

Are you using the source right now in your project?