Cocos2d-x 3.14.1 windows: missing openssl in external

Cocos2d-x 3.14.1 windows: missing openssl in external
0

#1

Hi,

I noticed that there is no openssl in external on cocos2d-x 3.14.1 on windows but the mac version has it? Is there a reason for it? Can I use the one from https://github.com/cocos2d/cocos2d-x-3rd-party-libs-bin instead?

Also if someone can explain how can I build my own openssl version if needed? I mean - are there any special cocos2d-x instruction on how to build it or maybe some special scripts/makefiles to stage it?

Keep up the good work! :slight_smile:

Best regards,
Samo


#2

how did you get 3.14.1? Our GitHub repo or the .zip from our website?


#3

website: http://www.cocos2d-x.org/filedown/cocos2d-x-3.14.1.zip


#4

Any updates on this?


#5

There seem to be a few other issues sort of related, so I am going to try setting up in a virtual machine and see how I make out.


#6

Did you get anywhere?


#7

I have windows build working. What can I help with?


#8

I just solved the issue on my end, where I had the wrong version of SSL installed. Moving to this instead worked https://slproweb.com/products/Win32OpenSSL.html. Not sure if that’s related to OP or not but it’s no longer an issue for me.