Cocos Studio keeps freezing on OSX

Cocos Studio 2.3.2 freezes on OSX 10.10.5 as soon as I try to open a Scene/Layer in the viewport. Tested on multiple machines with the same result. Does anyone experience the same issue? How to solve the problem?

Same problem. Can’t seem to do anything. Please someone give us feedback on this!

I tried and this happens for me as well. Let me report feedback…

Any updates on this issue… I’ve tried downloading again and installing with no sucess…

Is there a cocos studio rep where I could download a in development or unstable version to try? or maybe a previous version which works?

It is the first time i’ve used cocos studio and I’m just a little bit bothered by this. Maybe there is some sort of workaround?

In fact, Cocos Studio freezed for quite a long time when I tried to open a layer file. (I was running El Capitan). But after 20 minutes, it seemed to resume normal operation for me and I have yet to face the issue.

Regardless Yosemite or El Capitan, I had been facing the freezing issue for quite some time, and it occurs very randomly.

Same here after install El Capitan!

I have reported a few issues about this.

Uff good I didn’t installed El Capitan yet. Everything good on Yosemite (but studio can be slow sometimes).

We have fixed this bug, please try 3.10 version.

I’m running El Captian will updating to OS Sierra help this freezing issue?

Cocos Studio has been cancelled and is replaced with Cocos Creator. If you have to work with Cocos Studio and you still have that freezing problem, just wait for a while, it might take 20 min.

Good luck…

can I use cocos creator in conjuction with cocos2d-x c++.

c++ is not supported right now, but will be supported in the near future.

Keeps freezing randomly in Sierra 10.12.1, need some help/update!!

Me too… so sad!!

Hi! I found that if you disconnect internet works perfectly!! I’m working with Little Snitch (mac) to block internet connection for cocostudio


Nice find. I apologize, Cocos Studio has been EOL’d for some time now. We don’t test it with anything anymore. The last official release was v3.10.


# coco studio

to your `/etc/hosts` is a greet tool.

But still lots of developer are using Cocos2d-x and Cocos Studio

Could CocosStudio open source??

You’re a life savior! I didn’t have this freezes before, just recent days. There were super annoying - each 5 mins app frozen for 2mins… Your fix did the job, after restarting cocos studio it no longer (so far) freezes!