Cocos Dashboard Crashing on Mac

Hi, I’m currently on Mac OS and I was able to download the very first dashboard installer (CocosDashboard-v1.0.0-darwin-031318) and this one worked fine.

I then learned that dashboard auto-updates so what happened was it auto-updated to a corrupted version (CocosDashboard-v1.0.1-darwin-031816.dmg) where the dashboard was loading permanently and I couldn’t do anything.

It looks like someone reported the corrupted file here and this was supposed to be fixed already but now upon installing the “fixed” version, I can’t even open the app - it’s now crashing every time (CocosDashboard-v1.0.3-darwin-032111.dmg). I deleted everything in application folder related to cocoscreator and this still happens.

Apparently, having the dashboard auto-update to a corrupted build messes everything up. Maybe turn auto-update off by default and just present it as an option for now?

Anyway, it seems like the cocos dashboard is still far from perfect so could we just have direct links to the cocoscreator builds in the website downloads too? (I just learned that the cocoscreator 2.3.2. installer can be found here in the forums but I guess not everyone knows this.)

Is there anything in you can post?

Also, please re-read this post to answer your question about downloads: Cocos Creator v2.3.2 released, now using Cocos Dashboard

We can ask @jare to read this topic.

Thanks for your feedback

Did you have a problem updating to version 1.0.3?
Is the latest DMG unable to be installed or cannot be started after automatic update?

Some of the updates were found to be problematic, related to a file mechanism, which may also be related to the network.
Where are you from?
In addition, I would like to ask about your system version.

We will confirm the problem as soon as possible. Thanks again.

You can try deleting the $USER/.cocos /updater directory.
If possible, could you compress it and send it to us? Thanks.

I have deleted my dashboard installation when the previous problem auto-update issue arised (Not loading anything).

I just tried out installing again to see if it has fixed the issue but now I can’t open the application at all. The latest DMG can be installed but I can’t open the dashboard at all (it instantly closes).

I have deleted the $USER/.cocos/updater directory and issue still happens. Uploading it here as well just in case. (95.2 KB)

@slackmoehrle here are the only ones I can get from console related to the dashboard:


assessment denied for CocosDashboard-v1.0.3-darwin-032111.dmg bundle:UNBUNDLED denied:no usable signature CocosDashboard-v1.0.3-darwin-032111.dmg UNKNOWN 3

assessment granted for .app by Developer ID bundle:com.cocos.dashboard .app 1.0.3 granted:Developer ID 1

My system specs:
macOS Mojave 10.14.6 (18G103)
MacBook Pro: (Retina, 13-inch, Early 2015)
Processor: 3.1 GHz Intel Core i7
Memory: 16 GB 1867 MHz DDR3
Graphics: Intel Iris Graphics 6100 1536 MB

I’m from the Philippines.

We found a MAC(10.14.6), but were unable to reproduce the crash.

Can you run the program from the command line to see if there are any uncaptured error messages?

  1. Right click on to display package content
  2. Running Contents/MacOS/CocosDashbaord

This should output some useful information.

This is the download address of creator, you can use this link to download.

Thank you for your help.

Ok, here are the logs from console. It seems to be related to crypto operations?

Last login: Thu Mar 19 20:43:14 on ttys000

MacBook-Pro-4:~ rit$ /Applications/ ; exit;
(node:21894) [DEP0106] DeprecationWarning: crypto.createDecipher is deprecated.
Saving session…
…copying shared history…
…saving history…truncating history files…
Deleting expired sessions…85 completed.

[Process completed]