Cocos Creator v2.0 released!

Cocos Creator v2.0 released!
0

#22

Sorry, our main resources is focusing on Cocos Creator now

There are still some mistake in API docs, leads to snippet errors, we will fix whatever we found or reported in v2.0.1

It’s not supported anymore, we are using perspective projection in Camera, and it can’t be changed currently. For the frame size, normally you can change the container dom node’s css in index.html.

Checked, we will fix it, but it’s not causing any problem for now, you can just ignore

I don’t understand the first problem. As for Spine, there is two rendering bug in 2.0.0 which will be fixed in v2.0.1. You also showed that you first change the Animation to run then to shoot, but in runtime, it will only play shoot animation directly, so I think it’s the correct behavior.

Indeed the asset managing is updated in v1.10, how did you customize the old versions ?


What editor is recommended for Cocos Creator 2.0?
#23

Hi there!

Get errors while switching dragonBones resources (set another .dragonAsset and .dragonAtlasAsset for it) in dragonBones.ArmatureDisplay component on flight from code (in native and web). Also errors while calling destroy() for dragonBones.ArmatureDisplay component with loaded resources and running animation.


#24

Brilliant!

Yes, you are right.

Sorry, I didn’t explain myself here:
I also wanted to show that in 1.10 you see the first frame of the ‘run’ animation in the editor.
In 2.0 you do not see the first frame of the ‘run’ animation in the editor.

But hopefully this will be fixed with the 2.0.1 changes.

Thanks :slight_smile:


#25

Hello! Thanks for your hard work and efforts to release 2.0

I have few issues with EditBox component.

  • calling SetFocus() method somehow prevents emitting “editing-has-ended” event
  • you now unable to set editBox.node.width unless you put Widgets with Align=always on all three children of EditBox

1.10 works fine

2.0 with SetFocus() and stayOnTop=true

2.0 without calling setFocus() and stayOnTop=false

Source:
http://gg.gg/bbm9e

Windows 10
Cocos Creator 1.10/2.0


#26

Trying CocosCreator 2.0 on MacOS (OSX Yosemite) and I can’t run projects using the simulator. (Works fine in web browser.) Tried both a blank project and the Hello World project. Got (among other stuff):

Simulator: LOAD Js FILE: main.js
Simulator: ------------------------------------------------
Simulator: ERROR: TypeError: undefined is not a function (evaluating 'Object.assign(gfx, enums$1)'), location: src/cocos2d-jsb.js:34668:20
Simulator: [ERROR] Failed to invoke require, location: /Users/nantas/fireball-x/cocos2d-x-lite_20_release/cocos/scripting/js-bindings/manual/jsb_global.cpp:238
Simulator: ERROR: TypeError: undefined is not an object (evaluating 'cc.game.restart = function () {'
Simulator: ERROR: SyntaxError: Unexpected keyword 'const'. Const declarations are not supported in strict mode., location: jsb-adapter/engine/jsb-node.js:28:
Simulator: ERROR: SyntaxError: Unexpected use of reserved word 'let' in strict mode, location: jsb-adapter/engine/jsb-loader.js:53:
Simulator: ERROR: SyntaxError: Unexpected identifier 'KeyboardReturnType', location: jsb-adapter/engine/jsb-editbox.js:31:
Simulator: ERROR: TypeError: undefined is not an object (evaluating 'cc.debug.DebugMode'), location: main.js:76:32

Is this a known problem for Mac or do I possibly need to update my OS?


#27

Finally understood, it will be fixed in 2.0.1

I have created issue for it, not sure whether it will be fixed in v2.0.1, but don’t worry, we will keep an eye on it

You need to upgrade your Mac OS X, we are using more ES6 scripts in 2.0, and some of them are not transpiled, unfortunately, the JSC in Yosemite doesn’t support ES6, you will need 10.12 at least


#28

I am excited to upgrade to 2.0, but after upgrade, I get into trouble.
When use ParicleSytem, it will not work rightly as before, and the editor will warn ‘can not find the SpriteFrame used by the ParticleSystem’.

I do not do anything but open the project using the new version editor, and I just play the ParticleSystem editing by external editor.

(sorry for i can’t post the images, but you can try any one ParticalSystem file to reappear it)


#29

It’s due to ParticleSystem asset upgrade, we are parsing base64 to image file during import in 2.0, but apparently many base64 encoded image failed to be decoded in the current version. For such particle assets, you need to use external png to make running. But don’t worry, we will revert the asset upgrade in 2.0.1.

The warning you can just ignore it, we are finding some walk around to remove it, but it doesn’t do any harm


#30

The cc.Color.fromHSV function returns with wrong color. It seems that r-a components are mixed.


#31

The Scripts extends cc.Component already added in node don’t destroy affer node destroying…
my solves:

  • Override onDestroy() function and add below codes
    onDestroy() : void {
    this.destroy();
    }

#32
  • Camera rotation doesn’t work. Any solutions?

  • WeldJoint.getReactionForce() doesn’t work.

I’ve fixed problem via editing jsb:

      b2WeldJoint.prototype.GetReactionForce = function(inv_dt, out) {
        var out = out || cc.v2(); // added this line, second parameter was not passed by calling function
        out.x = inv_dt * this.m_impulse.x;
        out.y = inv_dt * this.m_impulse.y;
        return out;
      };
  • It doesn’t remember node’s fold/unfold states in the tree.

#33

All particle system data reverted to default when I opened scene while my particle system is using external PNG files and using custom settings without plist file.


#34

Generated APK cannot be installed on Android devices. Any solution for this?


#35

It doesn’t reveal related node in the node tree when I click on a property of component. It just highlights if node is already visible in tree.

component_property


#36

After uninstalling the previous version that was compiled with 1.9.3, I was able to install the new APK, but it does not run. The screen is black and nothing happens… :frowning:


#37

It folds/unfolds the component view when I click on the tickbox:
Capture

Console view doesn’t scroll down when new entry added:


#38

Hi! Thank you for the update! I just upgraded project and noticed that cc.textureCache is removed. I was using it to download a remote texture with cc.textureCache.addImageAsync function. Could you please tell me what is correct alternative to do this now in 2.0.0?


#39

Thanks, fixed

The components should be destroyed in Node’s _onPreDestroy, you can set a break point to check out

  1. We will support it in future versions, 2.1 probably
  2. We will fix the usage in getReactionForce
  3. It’s noted in issues

We will revert particle asset upgrade in v2.0.1, if you are using many particle assets, please wait until the next version

we need more informations, there must be some errors

noted, but won’t be fixed in v2.0.1

it’s intended behavior

if you have scrolled the console view to focus on some previous logs, it won’t scroll automatically when new log generated, you must re-scroll it to the bottom to enable the auto scroll

you need to use cc.loader.load(remoteUrl, function (error, texture) {
    // use your texture
})

#40

It seems that the JSON loader crashes on Android:

    // Load game data...
    var url = cc.url.raw( 'resources/gamedata.json' );
    cc.loader.load( url, function(err, res) {
        GlobalData.gameData = res.json;
    });

Is it OK to use res.json?

And the following code does not work on Android:

    cc.systemEvent.on(cc.SystemEvent.EventType.KEY_UP, function (event) {
        if ((event.keyCode == cc.KEY.back) || (event.keyCode == cc.KEY.backspace)) {
            // my event hander code...
        }
    }, this); 

It worked fine with 1.9.x.

Best regards,
Zsolt


#41

Under wine: Cocos creator can not be installed on systems with Windows Installer version smaller than 2.0, not work under virtual machine due to lack of 3D.