Cocos Creator v1.6.0 Beta Releases (Updated with rc.1)

Cocos Creator v1.6.0 Beta Releases (Updated with rc.1)
0.0 0


[BETA-3] Visibility toggle not working for me (was exploring camera demo). V-1.5.2 worked fine.


I have a couple of usability suggestions, they are not bugs, but kinda:

These text items are crushed in my smaller res screen. I noticed that the menus seem to all have tolltips, maybe everything else in the editor should too.

Also, it would be good if all of the “panels” were collapsible, that way i could hide the console, for instance, and open more space for the ‘scene’ panel

During a project creation, if you select one of the sample projects, like TS or the Collections, I believe it should rename the standard name bellow to the relevant project name:

In this case i had selected the Hello World TS project, so instead of “New Project” it should have been renamed to /Hello_TypeScript. That could avoid confusion.

Also, i tested the example collections, they seem really old and could use some attention, specially if you guys want english speakers to care about them.

On a side note, i got it running on an old phone here, via the lan testing, and some of the sprite samples ran really well, on the browser window, which is pretty cool. something like 33+fps for animations, and this phone is really laggy.

All in all you guys are doing great, I love what I"m seeing specially with the TS integration and VScode. :+1:

Let me know if there is anything else I can do to help with the above mentioned.


I had a few issues with beta 3 that were not present in 1.5.2, not sure if they were to be expected so…

When managing the size of collider polygons, i noticed that the up and down arrows would sometimes not work, unless i pressed exactly at the middle of the sprite. In 1.5.2 there is no such thing, it’s very smooth and effective.
Also, if i inputed the values directly, like say press 2 inside the value box, it would scroll to the top of the collider, moving the property out of focus.

I also noticed that adding “cc.director.getPhysicsManager().enabled = true;” to a script, activating physics, required an app restart, otherwise the screen would be black when running the sim.
Other things like console errors and auto-completion on vscode where also not working, maybe these are expected?

I made 2 equal physics minimal projects and tested on 1.6b3 & 1.5.2.


Hi! Is there any estimated date of the beta 4 release?


v1.6.0-beta.6.2 released on the Chinese forum:


The Chinese forum contains much more beta versions… I don’t really understand why is it so hard to post it here as well… :frowning:

@jake72, thanks for the link! :slight_smile:


Hey I just post updated beta release with changelog in English.

Sorry for the delay, it’s just tedious work translating all those changelist.


Many thanks for the updated link and for the translated changelog. I know it is tedious to translate all those texts, but at least please update the download link. With the google-translate I roughly know what changed. :slight_smile:


You can just keep an eye on the Chinese forums. It’s easy to see when there is a new beta out. For the change log I just use google translate and I can kinda get a gist of what has been fixed. For some reason Android is always translated to Andrew :slight_smile:


Frame Event editor, some parts don’t change language.


In 6.2 beta (and maybe earlier too) VSCode Chrome debug breakpoints don’t work (some issue with source maps probably?)


Hi in cc 1.6.2 when I import an asset to project I get following error:
Can not find import path [D:\sampleproject\library\imports\a1\a12e7b16-dcb3-430d-93ef-4132476a96b0.js] at Async.each (C:\CocosCreator\resources\app.asar\editor\core\quick-compiler.js:1:5170) at C:\CocosCreator\resources\app.asar\node_modules\async\lib\async.js:181:20 at Object.async.forEachOf.async.eachOf (C:\CocosCreator\resources\app.asar\node_modules\async\lib\async.js:233:13) at Object.async.forEach.async.each (C:\CocosCreator\resources\app.asar\node_modules\async\lib\async.js:209:22) at Object._compileScripts (C:\CocosCreator\resources\app.asar\editor\core\quick-compiler.js:1:5033) at complete (C:\CocosCreator\resources\app.asar\node_modules\lodash\lodash.js:8460:25) at Timeout.delayed [as _onTimeout] (C:\CocosCreator\resources\app.asar\node_modules\lodash\lodash.js:8470:11) at tryOnTimeout (timers.js:232:11) at Timer.listOnTimeout (timers.js:202:5)


Bug: If you add a keyframe to the animation and then delete it, the animation doesn’t change as the keyframe hasn’t been deleted.


They have revamped the JSB codes. Correct me if I’m wrong, I remember reading it somewhere that it broke debugger attachment like VSCode Chrome. Maybe try debugging it on the browser?


Tried debug in a browser, and it’s not so convenient but it works nevertheless) Thanks for an advice!


rc.1 colour editor did not register drag event. on slider drag the colour won’t get updated.


If you guys haven’t notice. Cocos Creator 1.6.0 is officially released:


I’m still waiting for the official release post in english forums with english information on whats new.
I mean, this: translated to english.

Have you tested it? how it goes? any major bugs?


i’m waiting pinned post to report issues


So far so good! And they actually fixed this issue:

I noticed there’s no more meta changes when you upgrade, and new ones would be default 1.0.0 version. Thanks Cocos Team.