Cocos Creator Resources - (UPDATED October 2019)


So I should stop looking at the documentation link I posted?

1 Like

I haven’t checked that link in months. The Creator Manual is the only documentation they are updating so far.

1 Like

Hello, so I wasn’t sure where else to post this but I was reading online about this editor and I was very excited to use it, however whenever I tried to load a project with the editor I received an error in the project’s log - Error: EPERM: operation not permitted, open ‘C:\Program Files (x86)\CocosCreator\resources\static\default-assets\image.meta’. I’m wondering if this has anything to do with the permissions of the program but I’m unsure, any help would be greatly appreciated. Thanks!

1 Like

Hello. I need help. I am working on the Cocos Creator Quick Start: " Creating your first Game." I am stuck on the part where we are “Writing the main character’s script.” 3. The guide asks me to “Right click the scripts folder, choose Create->JavaScript and create a JavaScript script 4. Rename the newly created script as Player. Double click this script and open the code editor.” But, when I double click script Player, I get an error message and no editor pops up. Script: C:\Start project\ start_project\assets\scripts\Player.j Error: Expected identifier, string or number. Source: Microsoft JScript compilation error.
Show less

1 Like

The internal editor is no longer there. Use VSCode to write your code.

1 Like

Hi there. Recently, I updated Cocos Creator to versions 1.7 and 1.8. After this, I opened my project (and also tried creating a new one), but instead of loading, I just get the message “Importing assets, please wait”. After waiting many hours, nothing has changed, and this occurs across multiple devices which Cocos Creator is installed on. I have also tried to use an older version, but this doesn’t make a difference as the latest version loads instead. Are there any suggestions for how to fix this? Thanks.

1 Like

Can you show us anything? I am not having this problem.

1 Like

It was happening with me on Windows. I had to right click Cocos Creator and execute as administrator, then it worked.

1 Like

Thanks, @bruno1308, running it as administrator fixed it.

Some super stupid questions:

Sorry for the stupid newbiness to this. I still don’t understand what this means: “unified, game development tool.”

  1. Does Cocos Creator only create JavaScript browser output? Or… does it also create native apps for iOS and Android etc? If so, how are the JavaScript scripts converted to C++ or whatever else they’re made into for running natively on devices?

// I really am asking about NATIVE native apps. Not wrapped web apps or other forms of wrapping HTML output into “native”.

  1. Where can I ask about how this works:

This page does not exist… see highlighted text:

The highlighted link goes to the same page the link immediately above it goes toooo…

I will check out the links that you mention and fix them.

You can deploy to a browser and iOS and Android.

You can ask any questions here and if I cannot answer them I will ask the engineering team for assistance.

1 Like

Is this truly native, or a wrapped HTML/Web app?

You can build a truly native app with Cocos Creator, yes. The conversion from JS to C++ is done by JSB (


Thank you @bruno1308. After reading down through as much of that link as I could… my eyes glazed over, my brain (such as it is) headed for shadows and consciousness slipped away.

What’s required (when using Cocos Creator and Javascript) to ensure a C++/Native compilation can be made for iOS?

Do I need to limit what I’m doing/using in terms of the API, or use JavaScript in a special way, or otherwise make considerations? Or can I simply use Cocos Creator and JavaScript as I please and it all “just works™”

Or Android…

But, truth be told, I don’t care about Android. :wink:

So it turns out that this “importing assets” problem only occurs when I open a project type in Cocos Creator other than an “Examples” project. Not sure why, especially when an Empty Project or Hello World would not need to import hardly any assets.

thanks in advance:grinning:

I actually have a problem with the new build. I’m following the “ Create Your First Game ” tutorial and I’m trying to find the Custom Component button,but I can’t. Is this normal or is it a bug. Please reply as soon as you can.

Have you tried clicking a node in a scene, then scrolling all the way down to the bottom of its properties panel on the right side of the screen and clicking the “Add Component” button? A menu will come up with “Add Custom Component” where you can access your scripts.