Cocos Creator GUI (Project Explorer) not show!

Cocos Creator GUI (Project Explorer) not show!
0.0 0

#1

Please help
I was using CocosCreator 1.22 on Windows 7 normally then I closed & reopened it, but the “project explorer” did not show. It appeared in taskBar but no windows get shown. (Looks like it has windows’ position =-10000).

Please let me know the engine behind Cocos Creator’s GUI so I have some clues to fix this bug.
I’ve tried using installer file to repair CocosCreator as well as disabled antivirus but without result.

Thanks a lot !


#2

The engine behind it is a lite version of Cocos2d-x. But I’m not sure how that will help you with the window not getting shown. Can you click on it in the task bar, perhaps it was minimized?


#3

If it were simply minimized then I did not need a post on this forum. I’ve tried restart my PC, run as Administrator and do all available things but nothing worked!
Is the GUI based on any exe-file that is disabled by antivirus?


#4

Or please tell me the way to run Cocos Creator directly with certain project without “Project Explorer” please!


#5

I’ve just removed Cocos Creator (removed all settings & files as well) and then installed it again. But the project explorer are still stuck at task bar and refused to show as a real window !

Anyone has any idea please?

I guess it relates to some kind of windows GUI platform in format of a “exe” file (such as hta for html-application based on mshta.exe, or javaApp based on javaRuntimeEnvironment) but as slackmoehrle answered, I don’t know the equivalent “exe” of cocos2d-x lite version to check what’s wrong with it.


#6

My Visual Studio 2015 (community version) has just expired, can that be the culprit? I’ve registered to extend the license of VS 2015 but that did not solve problem.
Can anyone please help @slackmoehrle @pandamicro !


#7

I don’t know the answer. Perhaps @pandamicro or @nantas2 have some thoughts. I will message them also to have a look at this thread.


#8

You can run with --path like: ".... creator.exe" --path D:\path_to_your_project

Please delete the C:\Path_to_user\.CocosCreator folder and try again.


#9

Thank you for the trick of command line.

Today I’ve formatted my drive C:, restore a previous GHO (ghost) file of my system to my PC (and come back to my system of 1 year ago). Then I installed a fresh copy of Cocos Creator, NDK, SDK, Python, JavaSDK, … I can’t remember all.

And of course, things worked well. But I’ll consider your suggestion the next time this problem occurs.
Thank you anyway!


#10

:joy: alright


#11

@jare @slackmoehrle

Today I’ve just faced this problem again and this time I figure out error source: (Found in windows event_log)

The program CocosCreator.exe version 1.1.3.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
 Process ID: 1160
 Start Time: 01d29aaddfe418a4
 Termination Time: 163
 Application Path: C:\CocosCreator\CocosCreator.exe
 Report Id: f7c8b9bb-06c8-11e7-b772-f07bcbe1710e

The GUI of Cocos creator was not responding ONCE only but I can’t open Cocos Creator EVER AFTER. The symptoms are exactly like what I’ve described in 1st post of this thread.

Juts post here to help Dev team fix it in later version (if not yet)
Thanks for reading


#12

By the way, doing it like jare suggested me did the trick !

Please delete the C:\Path_to_user\.CocosCreator folder and try again.

Thanks so much, you saved my day !