Cocos 2dx 3.17.1 can't compile release

Cocos 2dx 3.17.1 can't compile release
0
#1

#2

What did you try to run?

#3

cocos compile -p android —android-studio -m release

cocos compile -p android -m release

#4

COCOS_CONSOLE_ROOT D:\Cocos2dx\cocos2d-x-3.17\tools\cocos2d-console\bin

#5

cocos compile doesn’t work like that anymore. You should use Android Studio.

#6

I tried and the result was the same

#7

I tried ndk r16b and ndk r17c

#8

hmm, I’m working just fine.

@mars3142 I know you are on Android a lot. Does 3.17.1 and cocos new compile in Android Studio?

#9

I’m a bit of confused, because in the screenshots is framework/runtime-src the path.

@bayquabaoto can you paste the cocos create command? It seems to be a JS project and I never did it, so I need some help, so I can check it here. It can also be very helpful, if you call gradlew build in the proj.android folder and attach the log here.

@slackmoehrle I just created my default testing cpp project with js instead of cpp and it also stopped at the task mergeReleaseAssets. My sources were the latest github commit as of yesterday. It was the command cocos jscompile -s /path/project/frameworks/runtime-src/proj.android/app/build/intermediates/assets/release -d /path/project/frameworks/runtime-src/proj.android/app/build/intermediates/assets/release. Running this command in the terminal download the console binaries and compiled without any errors. But a new started gradlew build failed at the same tasks. I have currently no idea, because it’s not an Android specific issue. It’s an issue with the build script (build.gradle).

1 Like
#10

Yes, It is a JS project, I created it by cocos new HelloWorld -p com.game.helloworld -l js -d ./

#11

Thank you. We can create a GitHub issue for this, I think.

2 Likes
#12

@slackmoehrle Has this issue been resolved yet?

#13

@slackmoehrle Can you notify me when it is resolved?

#14

I created the issue in GitHub, I don’t know when engineering will fix this yet.

1 Like
#15

Me too when i tried build project js…
Can you help me about this issue?