Can't make Cocos2d-x on Ubuntu 18.04

Can't make Cocos2d-x on Ubuntu 18.04
0.0 0

#1

After make I’ve got this:

[ 68%] Building CXX object cocos/CMakeFiles/cocos2dInternal.dir/2d/CCActionCamera.cpp.o
In file included from /home/joe/cocos2d-x-3.16/cocos/platform/CCGL.h:43:0,
from /home/joe/cocos2d-x-3.16/cocos/base/ccTypes.h:36,
from /home/joe/cocos2d-x-3.16/cocos/base/CCProtocols.h:33,
from /home/joe/cocos2d-x-3.16/cocos/2d/CCNode.h:35,
from /home/joe/cocos2d-x-3.16/cocos/2d/CCSpriteFrame.h:31,
from /home/joe/cocos2d-x-3.16/cocos/2d/CCAnimation.h:34,
from /home/joe/cocos2d-x-3.16/cocos/2d/CCActionInterval.h:34,
from /home/joe/cocos2d-x-3.16/cocos/2d/CCActionCamera.h:31,
from /home/joe/cocos2d-x-3.16/cocos/2d/CCActionCamera.cpp:28:
/home/joe/cocos2d-x-3.16/cocos/platform/linux/CCGL-linux.h:31:10: fatal error: GL/glew.h: No such file or directory
#include “GL/glew.h”
^~~~~~~~~~~
compilation terminated.
cocos/CMakeFiles/cocos2dInternal.dir/build.make:86: recipe for target ‘cocos/CMakeFiles/cocos2dInternal.dir/2d/CCActionCamera.cpp.o’ failed
make[2]: *** [cocos/CMakeFiles/cocos2dInternal.dir/2d/CCActionCamera.cpp.o] Error 1
CMakeFiles/Makefile2:365: recipe for target ‘cocos/CMakeFiles/cocos2dInternal.dir/all’ failed
make[1]: *** [cocos/CMakeFiles/cocos2dInternal.dir/all] Error 2
Makefile:83: recipe for target ‘all’ failed
make: *** [all] Error 2


Can't make Cocos 2d-x on Ubuntu 17.10
#2

Did you install glew? Can you provide me your exact steps taken so far?


#3

It seems I have glew:

$ sudo apt-get install libglew2.0
Reading package lists… Done
Building dependency tree
Reading state information… Done
libglew2.0 is already the newest version (2.0.0-5).

I installed Ubuntu 18.04 instead of 17.10.
Then launched install-deps and it said that I have everything, then tried to cmake …/…
but it said that I have to install cmake, I did then.
After cmake …/… I tried to run make and got those error.


#4

Download-deps.py?


#5

I am going to write a new script for Linux


#6

Download-deps.py, right. Thank you very much.