Can't compile in Android after update

Can't compile in Android after update
0.0 0

#1

I have updated Android SDK to SDK version 24. Gradle syncs fine in Android Studio but using the command “cocos compile -m release -p android --android-studio” fails with errors:


The “android” command is deprecated.
For manual SDK, AVD, and project management, please use Android Studio.
For command-line tools, use tools/bin/sdkmanager and tools/bin/avdmanager


Invalid or unsupported command “update project -t android-15 -p /Users/jmclaveria/Documents/XCode/RamboatX/proj.android-studio/app”

Supported commands are:
android list target
android list avd
android list device
android create avd
android move avd
android delete avd
android list sdk
android update sdk
Error running command, return code: 2.

Have tried to download the new tools as said in this thread, but it didn’t work.

How can I compile my project with the command line?


#2

Well, after update to the last version Android Studio and company the command line output is “.cocos-project.json is not found”

I really hate Android, is a pain in the ass


#3

We still have an open issue on that in github.


#4

Thanks mate, you save my day :slight_smile:


#5

fixed in https://github.com/cocos2d/cocos2d-console/pull/410


#6

Hi @zhangxm , I also have the same problem but I don’t know what should I do with the given link? I can’t find any download button or so. Sorry for the noob question but I have never worked with github before.


#7

@sinhviencodon did you use git to get cocos2d-x source codes? If not, i think you can replace the corresponding lines in the corresponding lines of the console.


#8

that cool - now it will work with old and new one Android SDK? Is it included in 3.15 Rc0 or not yet?


#9