C++ and Lua support for creator alpha0 released

C++ and Lua support for creator alpha0 released
0.0 0

#63

@Darren_86 it seems there is not design resolution information in the Scene. Could you please share your creator project?


#64

@Darren_86 i fixed it in https://github.com/cocos2d/creator_to_cocos2dx/pull/14.


#65

@zhangxm wow u can fix it just like that :+1:

now i got different error:

TypeError: Cannot read property uuid of null
at Button.parse_properties (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:720:108)
at Function.create_node (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:133:15)
at Node.parse_child (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:423:30)
at Node. (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:391:18)
at Array.forEach (native)
at Node.parse_properties (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:390:35)
at Function.create_node (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:133:15)
at Node.parse_child (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:423:30)
at Node. (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:391:18)
at Array.forEach (native)

Properties
TypeError: Cannot read property ‘uuid’ of null

it’s underscore underscore uuid underscore underscore


#66

@Darren_86 This time i need your help to provide the creator project. Thanks.


#67

@Darren_86 your button widget doesn’t include normal sprite?


#68

@zhangxm there r some buttons that i don’t use sprite, but just the size.


#69

@Darren_86 I think i fixed the issue in https://github.com/cocos2d/creator_to_cocos2dx/pull/15. Could you please have a try? Thanks.


#70

@all now, the plugin can parse .fire files in subfolder of assets: https://github.com/cocos2d/creator_to_cocos2dx/pull/16

@Darren_86 i will release alpha2 after i help you to load the scene loaded from cocos studio.


#71

@zhangxm Button’s transition scale doesnt work!

The result is Sprite instead of Scaling.


#72

@Althurzard could you please share the creator project and paste some effects to describe what’s wrong. Thanks.
@Darren_86 what 's the progress of your project?


#73

@zhangxm after doing some isolation testings, i have found out that the problem is due to the ‘_action’ folder not being created when importing the .ccs project into creator.


#74

@zhangxm Here the clip.


The browser worked very well but when exporting to c++ and tested on simulator, it didnt affect.
I used the lastest branch.


#75

@Darren_86 i will take a look.
@Althurzard thanks for the information.


#76

@Althurzard i understood the issue now. The plugin can not support all features of creator, but i will try the best to support it, at least the features cocos studio has.

About this issue, can not support the Scale transition fully, for example, can not support the events. And with currently cocos2d-x, can not support the duration too. Of course can modify cocos2d-x to support duration, but can not support the events. Then i think i will not support the Scale transition, only Sprite transition. Because it will make it confused that some properties are not supported if i want to support Scale transition. And i will modify the README too.


#77

@Darren_86 so it is an issue of creator when importing cocos studio projects. And i saw some warning messages that

 Action for property "FrameEvent" is not supported.

So it seems actions are not supported when for the cocos studio project importing.
@jare Any idea of it?


#78

@zhangxm Oh wait…

I dont remember exactly but my old project used the previous branch in the old topic(before alpha version). And this feature was working well.

Here my completed project using creator c++

Maybe i should back to the previous branch -_-…


#79

Are you sure you use Scale transition? It is not supported from beginning.


#80

@zhangxm Yes i am


#81

@Althurzard did you remember which commit of the plugin you used? I will checkout and have a try. I checked the codes of CreatorReaderBinding.cpp, and the codes of creating and parsing Button are not changed. It doesn’t handle anything about Scale transition. So i don’t know why it can work.


#82

@zhangxm