C++ and Lua support for creator alpha0 released

C++ and Lua support for creator alpha0 released
0.0 0

#43

Thank you, that seems to fix the problem of the missing ccreator files. I will do some more testing tomorrow.


#44

Thanks.
Good to hear that it is fixed.


#45

It is strange, because the plugin only parses the .fire files in assets folder.


#46

No, this issue is not assigned to me, and @VirtualSJ is still working on AnySDK, he will fix this small problem in 1.5.


#47

I have no idea…

Yes it will


#48

I tried to export to android, I used cocos console:

  • cocos deploy -s [gamedir] -p android -m release

the release apk is built, i put it on the phone, and when trying to install the phone complains and says:
version: N/A
size: N/A
Package Name: N/A

( install ) —>

  • “Analysis Error: an error was produced during the package analysis”
    Cant install release version

well… i have no idea what could have been wrong. hahaha.
I exported the exactly same way than before but this fails

debug versions does not have any problem to create or installor run,
but the game still crashes when the ccreator reader is used:

error log from device:
debug info: cocos2d: fullPathForFilename: No file found at creator/level\1.png. Possible missing file.
debug info: cocos2d: fullPathForFilename: No file found at creator/level\7.png. Possible missing file.
debug info: cocos2d: fullPathForFilename: No file found at creator/level\8.png. Possible missing file.
debug info: cocos2d: fullPathForFilename: No file found at creator/level\9.png. Possible missing file.
debug info: NodeTree: 0xb860d2e8
debug info: Assert failed: Invalid spriteFrameName :1
com.Company.game2 E/cocos2d-x assert: [gamedir]/cocos2d/cocos/./2d/CCSprite.cpp function:setSpriteFrame line:1470
com.Company.game2 A/libc: Fatal signal 11 (SIGSEGV), code 1, fault addr 0x1c in tid 7220 (GLThread 4954)


#49

Does this error only happen on release mode? It seems it is nothing with release mode or not.


#50

no, release version couldnt even be installed in the phone.
an error ocurred while installing the release version: “Analysis Error: an error was produced during the package analysis”
so I couldnt run release version on android

this debug info is from debug version on android


#51

I haven’t missed the same value? How can i reproduce it? Would you mind sharing your creator project?


#52

sure, is a VERY basic project :confused:
creator_project - yaaashua.zip (1.2 MB)

all my relevant code is:

main scene:

if(actionLayer = GameLayer::create("creator/level1_game.ccreator"))
{
     addChild(actionLayer);
    actionLayer->Initialize();
}

if(UI = UILayer::create("creator/level1_ui.ccreator"))
{
	addChild(UI);
	UI->Initialize();
}

where anyLayer::create() is:

creator::CreatorReader* reader = creator::CreatorReader::createWithFilename(sourceFile);
if(reader)
{
	reader->setup();
	Scene* scene = reader->getSceneGraph();
	if(scene)
	{
          [remove every child of scene and add him as child of this layer]
        } 
 }

#53

Thanks, could you please also upload the Classes folder too? Thanks.


#54

I tried the project, and can run level1_game.ccreator and level1_ui.ccreator. And i know why removed scenes are still been parsed, the plugin should remove creator and json folder every time.

Edit: send the PR to fix the bug that deleted scenes are parsed.


#55

I guess the code is a bit more difficult to share, since I am implementing my own file readers and that brings more compllications :pensive:


#56

Omg! I am c++ user so I have Imported coco studio project in creator and its not importing Armature from coco studio. Does any know how to do that? Is that Armature is just not working with me or its with everyone? I saw Trello for cocos creator, meanwhile researching on new advance Armature system, Its better we can at least implement the older ones from coco studio.


#57

@gplayers could you please create another topic in creator category?


#58

@zhangxm sorry for that here is the topic about it. Support for Old Armature data in cocos creator


#59

I would really like to use an editor for scenes, but this seems to have issues? How long until you think it will be stable?


#60

If more developers help to test it, then it will be much quicker to be stable.


#61

Fair enough. Will soon… :slight_smile:


#62

I’ve tested it with the project that i’ve imported from cocos studio.
This is the error that i get:

TypeError: Cannot read property ‘width’ of null
at FireParser.to_json_setup_design_resolution (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:947:46)
at FireParser.to_json_setup (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:940:14)
at state._json_data.forEach.obj (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:1063:22)
at Array.forEach (native)
at FireParser.run (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:1055:26)
at C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:1084:16
at Array.forEach (native)
at parse_fire (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\ConvertFireToJson.js:1081:15)
at BuildWorker._convertFireToJson (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\BuildWorker.js:40:32)
at BuildWorker. (C:\Users\user\Documents\NewProject\packages\creator-luacpp-support\core\BuildWorker.js:29:41)

Properties
TypeError: Cannot read property ‘width’ of null