C++ and Lua support for creator alpha0 released

C++ and Lua support for creator alpha0 released
0.0 0

#90

@Althurzard add button scale transition: https://github.com/cocos2d/creator_to_cocos2dx/pull/17


#91

it works now!


#92

@Althurzard glad to hear that. I will release alpha1 quickly.


#93

I released alpha1 version: C++ and Lua support for creator alpha1 released.

Thanks for your feedback.


#94

@zhangxm
i’ve just started to test on loading the scene that is exported from the plugin. But the scene created doesn’t seem to have the correct number of children as what i am expecting… it is just a blank scene. Will pm you my project file.


#95

@Darren_86 i will take a look. And please give feedback in C++ and Lua support for creator alpha1 released, i think you already used alpha1 version. Right?


#96

@Darren_86 it is because widget is not supported right now. I am not sure if can support it in cocos2d-x.


#97

@Darren_86 sorry, it is not just about widget, there is something other error too, but widget can not be supported in cocos2d-x.


#98

@zhangxm yes, using alpha1 version, exporting has no error but the file does not have what it is supposed to have in the cocos creator as you mentioned about the widget issue :’(


#99

is the C++ suport for creator included in the Creator v.1.5?


#100

No, it is not stable now. And we need more developers to test it. It is a plugin, not have to shift with Creator, i will upload to plugin market when it is stable.


#101

Is there any way of getting the widget data into cocos2d-x? It’s crucial for GUIs and dealing with devices that have different aspect ratios. I need it so that the scene layout looks nice on all devices. The plugin is pretty useless without it.


#102

@kwellman creator uses a different UI system, so can not easily support Widget.


#103

@kwellman after dig into creator, i found the plugin already supports widgets, but the widget can only AlignOnce. If want to support align in runtime, then

  • plugin should retain the target it aligns to and the node which is will do align
  • when the target or node is deleted by codes, then plugin(reader and other codes) doesn’t know it, so target and node will not been deleted, which is error.

If plugin doesn’t retain them, then they will be wild pointer. So we can only align the Widget once.


#104

If I want to BUILD… I got this error:
I have to buttons in the scene… the state (normal/pressed) is marked with COLOR as transition - not with sprite.


#105

Did you use latest github codes? Could you please provide a creator project to reproduce it? Thanks.


#106

Hi, I’ve desperately trying to run example project, but it just doesn’t work. I’ve added “reader” in my Classes directory (via Xcode), I can include: #include “reader/CreatorReader.h” but when trying to run the app I’m getting tons of linker errors. Can you provide already configured HelloWorld project with creator support? Note that I’m using precompiled cocos2d-x (3.14.1). Should I have to include reader classes inside cocos and recompile library or can they be outside of it?

32


#107

I think you don’t include reader folder correctly, how did you include it? Could you please should me the screenshot of Xcode folder structure? Yep, i will use a branch of my personal cocos2d-x repo to test the plugin in future.


#108

23


#109

Great job!