Buildbox gamebreaking audio bugs with AudioEngine cocos code in XCode.


I am having issues with my Buildbox projects. When a Buildbox project is exported to Android/iOS they contain cocos-2d code. That’s why I am making this thread.

The bug they currently have is that after an ad is completed, all background sounds self disable. To resolve the issue, the user has to quit the app and reboot it. A bit of an inconvenience to the player.

In the debugger in XCode, this error code comes up:

E/AudioPlayer (217): bool cocos2d::experimental::AudioPlayer: Play2d():alSourcePlay error code:a003

I am running IronSource ads. If it’s a static video ad, then this bug doesn’t happen. Only on video interstitials. I have updated XCode and Buildbox multiple times and this bug persists.

I have tried removing SimpleAudioEngine code and it doesn’t get rid of the bug. I’ve also tried the opposite by keeping the SimpleAudioEngine code and removing the AudioEngine code and that doesn’t work either. So I am a bit lost on what to do, but the more I look at it, I think it’s to do with the cocos-2d code.